Trailer lights - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 07-21-2014, 10:16 AM Thread Starter
Member
 
Join Date: Jul 2014
Posts: 40
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Trailer lights

Hi guys. This is my first post! Recently purchased a 2005 F350 6 litre Power stroke diesel. My trailer signal/stop lamps work. My trailer head lamps don't. They were working for a bit and now there not. Any suggestions? Thanx
Dennis.t is offline  
post #2 of 9 Old 07-22-2014, 08:37 AM
,,,,,,,,,,,,,,,,,,,,,,,,,
 
ZMANN's Avatar
 
Join Date: Feb 2008
Posts: 14,564
Mentioned: 53 Post(s)
Tagged: 0 Thread(s)
Quoted: 556 Post(s)
Thanks: 523
Thanked 698 Times in 665 Posts
Feedback Score: 0 reviews
trailer head lamps ? i usually tow my trailer from behind so I don't have headlamps on it ;-)

.
.
.
Please donate to DTR Ron's Memorial
https://www.gofundme.com/2464axqr
We Miss you Ronnie
RIP
ZMANN is offline  
post #3 of 9 Old 07-22-2014, 08:40 AM
Super Moderator


 
SuperCrutyPS's Avatar
 
Join Date: Jul 2008
Location: Orangevale, CA
Posts: 14,967
Mentioned: 1 Post(s)
Tagged: 1 Thread(s)
Quoted: 212 Post(s)
Thanks: 76
Thanked 455 Times in 439 Posts
Garage
Feedback Score: 0 reviews
I'm guessing you mean tail or running lights?

Check your owners manual to see if there is separate fuse in the Power Distribution box under the hood for trailer running lights.


Owner | Operator: Darryl
My Truck: Ol' Guy Garage
Tow Toy: Pilgrim International 31RE3SLF5
United States Navy - IC2 - '76-'80
SuperCrutyPS is offline  
post #4 of 9 Old 07-22-2014, 09:54 AM Thread Starter
Member
 
Join Date: Jul 2014
Posts: 40
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by ZMANN View Post
trailer head lamps ? i usually tow my trailer from behind so I don't have headlamps on it ;-)
Can the smart *** remarks dude.
Dennis.t is offline  
post #5 of 9 Old 07-22-2014, 09:56 AM Thread Starter
Member
 
Join Date: Jul 2014
Posts: 40
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by SuperCrutyPS View Post
I'm guessing you mean tail or running lights?

Check your owners manual to see if there is separate fuse in the Power Distribution box under the hood for trailer running lights.
Yah, cant seem to see where the trailer running lights fuse would be in the fuse box. I find the fuse diagram not labeling the items very clearly.
Dennis.t is offline  
post #6 of 9 Old 07-22-2014, 10:09 AM
,,,,,,,,,,,,,,,,,,,,,,,,,
 
ZMANN's Avatar
 
Join Date: Feb 2008
Posts: 14,564
Mentioned: 53 Post(s)
Tagged: 0 Thread(s)
Quoted: 556 Post(s)
Thanks: 523
Thanked 698 Times in 665 Posts
Feedback Score: 0 reviews
do you have a test light or multimeter ?
or are you sure the problem is on the truck side of the connections

do you have an owners manual with fuse locations ?
if not use this no need for the log in just fill in the truck specs
https://owner.ford.com/servlet/Conte...OwnerGuidePage

smartass comments are a given on here but there is no charge ;- )

.
.
.
Please donate to DTR Ron's Memorial
https://www.gofundme.com/2464axqr
We Miss you Ronnie
RIP
ZMANN is offline  
post #7 of 9 Old 07-22-2014, 10:20 AM Thread Starter
Member
 
Join Date: Jul 2014
Posts: 40
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by ZMANN View Post
do you have a test light or multimeter ?
or are you sure the problem is on the truck side of the connections

do you have an owners manual with fuse locations ?
if not use this no need for the log in just fill in the truck specs
https://owner.ford.com/servlet/Conte...OwnerGuidePage

smartass comments are a given on here but there is no charge ;- )
Yes,its on the truck side, cause both of my 2 trailers, running lights not working when hooked up to the truck.
Dennis.t is offline  
post #8 of 9 Old 07-23-2014, 07:03 AM
Super Moderator


 
SuperCrutyPS's Avatar
 
Join Date: Jul 2008
Location: Orangevale, CA
Posts: 14,967
Mentioned: 1 Post(s)
Tagged: 1 Thread(s)
Quoted: 212 Post(s)
Thanks: 76
Thanked 455 Times in 439 Posts
Garage
Feedback Score: 0 reviews
Using the manual from the link above (2005 F350), Passenger Compartment Fuse Panel. Page 219, Fuse 38 20A* - Trailer Tow Park Lamps. * - Indicates a mini fuse.
Page 218 shows the fuse box layout.


Owner | Operator: Darryl
My Truck: Ol' Guy Garage
Tow Toy: Pilgrim International 31RE3SLF5
United States Navy - IC2 - '76-'80
SuperCrutyPS is offline  
post #9 of 9 Old 07-23-2014, 08:30 AM Thread Starter
Member
 
Join Date: Jul 2014
Posts: 40
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by SuperCrutyPS View Post
Using the manual from the link above (2005 F350), Passenger Compartment Fuse Panel. Page 219, Fuse 38 20A* - Trailer Tow Park Lamps. * - Indicates a mini fuse.
Page 218 shows the fuse box layout.
Thanx dude, I will try that!
Dennis.t is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome