6.0 AC Module stopped working - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 07-14-2014, 11:59 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2014
Location: Gainesville,GA
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
6.0 AC Module stopped working

I had my ac blowing full blast first of few times I have ever used my ac. Pulled up to a light put it in park raised the wheel to turn to the back seat when I turned back around my ac was shut off completely! No lights work, no air nothing! I tried the old unhook the battery, fuse check and turning my lights on and off tricks but nothing worked. I was told to make sure my heated seats were workin or not and they still come on automatically. If anybody has been in this situation before please let me know any input is greatly appreciated! Hoping I just pulled a wire loose but expecting to have to have the module replaced.
JT927 is offline  
post #2 of 8 Old 07-15-2014, 09:31 PM
Member
 
05_HARLEY_F250's Avatar
 
Join Date: Nov 2012
Posts: 66
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
Which module do you have?, are there controls in the steering wheel?

It sounds like there's something going on in your tilt, mine does it when the I tilt all the way down and sometimes at random, never could find the problem wire and after replacing the fuse every time it did it I bought a 15A mini buss breaker at autozone and modified my fuse box cover to allow it.
05_HARLEY_F250 is offline  
post #3 of 8 Old 07-16-2014, 01:03 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2014
Location: Gainesville,GA
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yeah there's steering controls and it's the automatic climate control unit.
JT927 is offline  
post #4 of 8 Old 07-16-2014, 01:36 PM
,,,,,,,,,,,,,,,,,,,,,,,,,
 
ZMANN's Avatar
 
Join Date: Feb 2008
Posts: 14,471
Mentioned: 51 Post(s)
Tagged: 0 Thread(s)
Quoted: 540 Post(s)
Thanks: 496
Thanked 695 Times in 662 Posts
Feedback Score: 0 reviews
Quote:
heated seats come on automatically ?
do you have the fuse locations so you can verify the AC fuses are OK ??


any thing else out at all ? dome ? dash wise ? ETC

radio ? if the radio works do any of the other steering wheel controls work ?

.
.
.
Please donate to DTR Ron's Memorial
https://www.gofundme.com/2464axqr
We Miss you Ronnie
RIP
ZMANN is online now  
post #5 of 8 Old 07-17-2014, 09:59 AM
Member
 
05_HARLEY_F250's Avatar
 
Join Date: Nov 2012
Posts: 66
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
Couldn't swear to it but I think the A/C control is on it's own fuse, I can't remember. I've pulled half the interior out and could never find the problem, it's bound to be in the steering column, I've only had it go out once since I installed the breaker but then again I don't move my tilt much.
05_HARLEY_F250 is offline  
post #6 of 8 Old 07-17-2014, 11:08 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2014
Location: Gainesville,GA
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
yeah my heated seats still come on automatically and my trailer brake module thingy still comes on and works. all wires underneath steering are plugged in tightly. I appreciate the help guys I just hope I can find the problem elsewhere before having to take the dash apart!
JT927 is offline  
post #7 of 8 Old 09-14-2014, 01:42 PM
Premium Member
 
firstresponder01's Avatar
 
Join Date: Aug 2014
Location: Austin, Texas
Posts: 36
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Mine just did this today. Heated seats work as well as the all the steering controls. Did you eve find out what it was?
firstresponder01 is offline  
post #8 of 8 Old 09-15-2014, 03:17 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2014
Location: Gainesville,GA
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yes mine was a fuse but the tricky thing was I only checked one fuse check every fuse that has do do with the module because I think there is a couple fuses that work the module. Now she runs like a charm let me know how it goes!
JT927 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome