2005 Radio upgrade and loss of speedo - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 06-08-2014, 10:40 AM Thread Starter
Powerstroke.org Rookie
 
IFixAircraft's Avatar
 
Join Date: Jun 2013
Location: Indianapolis
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2005 Radio upgrade and loss of speedo

On my 2005 6.0L I have installed a new radio. All works well except now the Speedo is inop and the truck seems to be running in a decreased power mode. If I put the factory radio back in all works just fine. There must be a VSS wire that I'm missing. Any help??
IFixAircraft is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome