Exterior Thermostat Issue - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 3 Old 01-15-2014, 09:35 AM Thread Starter
Powerstroke.org Rookie
04Powerstroke60's Avatar
Join Date: Dec 2013
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Exterior Thermostat Issue

Wasn't sure where to post this but to me it would be more of an electrical issue. 2004 6.0 191XXX miles. The exterior thermometer up on top reads -40 all the time. It's obviously faulty and it was like that when I bought the truck. It's not a huge deal to me since I can check the temperature on my iPhone.. but it would be nice to get it working again. Anyone have any idea where I should even start? Or where the sensor is outside the truck so I can check that?
04Powerstroke60 is offline  
Sponsored Links
post #2 of 3 Old 01-20-2014, 07:45 PM
Compression Ignition Addict
PowerStrokedRedneck's Avatar
Join Date: Apr 2011
Posts: 211
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 6 Times in 6 Posts
Feedback Score: 0 reviews
I'm having the same issue with mine. The sensor is up in front of the radiator behind the grill on the drivers side. I've already tried replacing mine with no luck. I would like to know. It's just rather annoying.

Sent from AutoGuide.com App
PowerStrokedRedneck is offline  
post #3 of 3 Old 01-23-2014, 06:34 PM
msizemore3's Avatar
Join Date: Apr 2011
Location: West Tennessee
Posts: 82
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
I believe -40 is the default value it shows when it's not plugged in or there is an existing short in the wiring. It is usually only a two wire connector that runs to the temp sensor. If you find the wires are chafed or cut just solder them back together. Since it works off resistance it won't matter which way you hook the wires back up with regard to pin location 1 or 2.

Sent from AutoGuide.com App

06 F250 KR 4x4, 5R110 w/ Banks Tq. Conv., Turbo Back Magnaflo Ex., SCT w/ ID--Gearhead--Looney Tunes, Retro-Solutions HIDS--Head & Fog, Zoodad Mod, Coolant Filter, High-Idle Mod, 35" Terras, Leveled, Homeade Adj. Track Bar, Rancho Dual St. Stab. Kit, Back-up Lights, PHP Atlas 40, Guages, Back-up Camera, CAT EC-1 Coolant
msizemore3 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome