Edge Insight CTS - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 01-13-2014, 06:10 AM Thread Starter
Premium Member
 
07DIESEL6L's Avatar
 
Join Date: Jun 2007
Location: Southern MD
Posts: 97
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Edge Insight CTS

Wondering if the members have seen anything weird with these units before. I just got my truck all back together after doing studs and injectors and put the turbo timer on it while I was putting it back together.

Well the second day I drove it I turned the key off and the truck keep running like its supposed to and shut off, came back about an hour later and turned the key but nothing. Could hear the starter relay engaging but the starter wasn't turning, unplugged the OBDII cable from the CTS and the truck started right up. The next day I went out to start the truck and it was sluggish like the battery was almost dead, so I disconnected both batteries and load tested them. They checked out fine, unplugged the CTS again and every time since then the truck has started just fine, no sluggish start or starter not engaging.

Any thoughts?
07DIESEL6L is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 01-13-2014, 11:24 AM
Member
 
Join Date: Aug 2013
Location: Corona CA
Posts: 34
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 0
Thanked 2 Times in 1 Post
Feedback Score: 0 reviews
I disconnected the + of the driver's side battery to do something and when I went to start the truck, the CTS was dead. Had to unplug it from the OBDII and plug it back in to work. Maybe the CTS is drawing a current through the OBDII while the truck is off. Dunno. Works fine since that.
superchaos is offline  
post #3 of 5 Old 01-13-2014, 12:09 PM
Premium Member
 
DVCF450's Avatar
 
Join Date: Feb 2010
Location: The Great Land
Posts: 96
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have had an anomaly with my Insight since I installed a BatteryMinder 2012-AGM.
If I plug the truck into shorepower (120 VAC) overnight I have to unplug and re-plug the Insight into the OBD-II port. The techs at Edge products are baffled, but do not think I am doing any damage to their unit.
My shorepower supplies the BatteryMinder, and the block heater. I guess there is some sort of voltage fluctuation during charging which confuses the Insight. Just one extra step in the morning!

2005 F-450 4WD DRW, 2x Deka 665MFs, 55w 6k headlights, BPD EGR cooler,BPD 100mm water pump,BPD all aluminum radiator,DC Power 190 amp Alternator,Utility box,high idle mod.,Sinister coolant filter, home built radio center console, Fumoto oil valve, Edge insight with SCT SF-3 in overhead mount,blue spring mod., BPD FICM, Derale deep cooling pan, BPD oil cooler, Jasper engine block & heads, ARP headstuds
DVCF450 is offline  
post #4 of 5 Old 01-13-2014, 12:12 PM Thread Starter
Premium Member
 
07DIESEL6L's Avatar
 
Join Date: Jun 2007
Location: Southern MD
Posts: 97
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
DVCF450 what do you use to plug in your shore power? I'm looking at maybe getting a kussmaul auto eject. We use them on our fire engines and they work perfect didn't know if you had a similar setup or not?


Sent from AutoGuide.com Free App

07DIESEL6L

Bulletproofed
RCD EGR Delete
Sinister Diesel Coolant Filtration Kit
Warren Diesel 175/Stock injectors
ARP Studs
H&S Cold Air Intake
Mishimoto Intercooler Piping Kit
5" MBRP Turbo back with 8" Tip
Stock Turbo with billet wheel
Innovative 58v Tuned FICM
Tuning by IDP
07DIESEL6L is offline  
post #5 of 5 Old 01-13-2014, 12:47 PM
Premium Member
 
DVCF450's Avatar
 
Join Date: Feb 2010
Location: The Great Land
Posts: 96
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I am familiar with those auto-ejects, but do not have one on my rig. I fabricated an inlet using Grainger part # 3D855 inlet and 3D463 cover. A cable goes up along the frame to the engine compartment, and into a junction box which splits off the block heater power and Insight feeder. Here are some pics. Hope they arrive O.K.
Be safe!
Attached Thumbnails
Click image for larger version

Name:	IMG_20140113_123749_810.jpg
Views:	62
Size:	95.7 KB
ID:	225930   Click image for larger version

Name:	IMG_20140113_123806_118.jpg
Views:	55
Size:	92.3 KB
ID:	225938   Click image for larger version

Name:	IMG_20140113_123830_100.jpg
Views:	49
Size:	99.4 KB
ID:	225946  

2005 F-450 4WD DRW, 2x Deka 665MFs, 55w 6k headlights, BPD EGR cooler,BPD 100mm water pump,BPD all aluminum radiator,DC Power 190 amp Alternator,Utility box,high idle mod.,Sinister coolant filter, home built radio center console, Fumoto oil valve, Edge insight with SCT SF-3 in overhead mount,blue spring mod., BPD FICM, Derale deep cooling pan, BPD oil cooler, Jasper engine block & heads, ARP headstuds
DVCF450 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome