Upfitter wiring check - Ford Powerstroke Diesel Forum

6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 01-11-2014, 10:47 AM Thread Starter
Member
 
FordPSD6.0's Avatar
 
Join Date: May 2007
Location: S Jersey shore
Posts: 63
Thanks: 8
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Upfitter wiring check

Hi,

I hooked up two pair of KC lights on my truck using the upfitter switches. I used the red and the black wires. The lights on the black wire are fine but the lights on the red wire don't work. I swapped fuses and relays with the working lights to see if it made a difference. It didn't. So how do you check the red wire under the hood to find out if you're getting juice? I'm not too electrical smart so talk in laymen terms. I do have a meter. Thanks.

2007 F-250 Lariat PSD 6.0 4x4 Crew Cab
FordPSD6.0 is offline  
post #2 of 4 Old 01-11-2014, 11:23 AM
Compression Ignition Addict
 
wvrrcarknocker's Avatar
 
Join Date: Sep 2012
Location: Louisville, KY
Posts: 422
Thanks: 13
Thanked 16 Times in 16 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 3 reviews
Send a message via Yahoo to wvrrcarknocker
The red, black, blue and white wires are just pass through wires. What switches did you wire them to?
wvrrcarknocker is offline  
post #3 of 4 Old 01-11-2014, 11:35 AM Thread Starter
Member
 
FordPSD6.0's Avatar
 
Join Date: May 2007
Location: S Jersey shore
Posts: 63
Thanks: 8
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by wvrrcarknocker View Post
The red, black, blue and white wires are just pass through wires. What switches did you wire them to?
I wired the pass thru's to the 30 amp upfitter switches. Orange/lt green upfitter wire to pass thru red and orange upfitter wire to black pass thru. The lights on the black wire are fine. It's the red pass thru I want to check for voltage under the hood and work from there. I might not have made a good connection under the dash because it was so stinkin tight under there.

2007 F-250 Lariat PSD 6.0 4x4 Crew Cab
FordPSD6.0 is offline  
post #4 of 4 Old 01-11-2014, 11:39 AM
Compression Ignition Addict
 
wvrrcarknocker's Avatar
 
Join Date: Sep 2012
Location: Louisville, KY
Posts: 422
Thanks: 13
Thanked 16 Times in 16 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 3 reviews
Send a message via Yahoo to wvrrcarknocker
I'd check your connections again. That really sounds like the likely issue, as the rest is factory.
wvrrcarknocker is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome