05 heat blower not working all the time? - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-05-2013, 04:40 PM
Member
 

Join Date: Jun 2013
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
05 heat blower not working all the time?

Have a 05 SD,problem is sometimes when I start the truck,the heater controls will not work,no fan speed or cant change the vents.not always but the odd time,it is needed now that the cold is here,after I drive around for a couple of minutes it will start working on its own?no change if I play with the knobs either,not a big deal but it is annoying. Also is there a light in the heater control that can be replaced?,mine is in darkness now,my truck does not have the climate control type of controls. Harvey
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-05-2013, 08:19 PM
Powerstroke.org Rookie
 

Join Date: Nov 2013
Location: virginia
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
do you have the fancy digital controls
Reply With Quote Quick reply to this message
  #3  
Old 12-06-2013, 02:21 AM
Member
 

Join Date: Jun 2013
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No,it just has the basic one,it almost seems like it is vacuum related?
Reply With Quote Quick reply to this message
  #4  
Old 12-09-2013, 06:31 PM
Powerstroke.org Rookie
 

Join Date: Nov 2013
Location: virginia
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ok sounds like you need a new blower fan resistor youtube has videos on how to replace them really really simple only takes about 10 minutes to do. oreily's has oem motorcraft resistors for like 15 bucks.
Reply With Quote Quick reply to this message
  #5  
Old 12-14-2013, 05:56 PM
Powerstroke.org Fanatic
 

Join Date: May 2009
Location: altoona , pa
Posts: 100
Thanks: 12
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Subscribed ... same problem same year . Like to hear your outcome after that resistor replacement
Reply With Quote Quick reply to this message
  #6  
Old 12-16-2013, 05:02 AM
Powerstroke.org Fanatic
 

Join Date: May 2009
Location: altoona , pa
Posts: 100
Thanks: 12
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Just bought a blower fan resistor for my truck... he turned on and was blowing good on all speeds. Shut the truck off went out 2 hours later to leave and again my fan isn't blowing . Any ideas ?
Reply With Quote Quick reply to this message
  #7  
Old 12-16-2013, 05:18 AM
Member
 

Join Date: Jun 2013
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
in one of my earlier posts I mentioned it seemed to be vacuum related,has anyone had any experience with the vacuum pump under the hood,it is over by the heater box?,somehow I think it is something to do with that. Harvey
Reply With Quote Quick reply to this message
  #8  
Old 12-19-2013, 05:46 AM
Powerstroke.org Fanatic
 

Join Date: May 2009
Location: altoona , pa
Posts: 100
Thanks: 12
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I replaced the resistor ... still didn't work . Sacked the blower motor with a hammer and it fired up . Replaced motor 58$ and its all fixed
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:46 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors