Parasitic battery drain - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 11-30-2013, 11:32 AM Thread Starter
Premium Member
 
Swackhamer's Avatar
 
Join Date: Jun 2013
Location: Zionsville
Posts: 113
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 9
Thanked 6 Times in 6 Posts
Feedback Score: 0 reviews
Parasitic battery drain

I have been trying to trace out a slow drain on my 04. What I have it traced down to are
#1 fuse #12 cigar lighter/ODB II .01amp
#2 fuse #35 Inst cluster .05amp
can anyone let me know if these are normal or not? I could believe that the ODB would draw .01 to keep somthing live, but the cluster seems out of line to me. I would think when the truck is off the cluster would be completley dead. Thanks

04 F250 Leveled, Studed, Atlas40,SRL+, Blue spring, 304 ss Up Pipes,KC stg II,ported intake, 4" exhaust, Head vents, Cat ELC and coolant filter, Custom Bumper,304 degas tank, More home brew mods in the works.
Swackhamer is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome