New Instrument Cluster, now radio won't shut off/interior lights don't come on. - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 11-01-2013, 06:26 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jun 2013
Posts: 9
Thanks: 1
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
New Instrument Cluster, now radio won't shut off/interior lights don't come on.

2006 F-350 XLT 6.0 Standard Cab...

So I had an issue with my Check Engine light, and the small dealer replaced my instrument cluster with a used one. Everything works fine except for the fact that when I shut my car off and open the door, the aftermarket radio (that I installed, and which was working fine before the new cluster) doesn't shut off. I have to remove the face plate to shut off the radio, and even then I'm not sure if the radio is still active and sucking juice from my batteries. Also, the interior lights do not come on when I open my doors. They used to, now they don't. I can manually turn the interior light controller all the way up to turn them on, but they do not automatically turn on when the doors open.

Anyone have any clues as to the connection between a new, used IC and the electrical issues I'm having with the radio and interior lights?

Thank you!
surfmotion is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 11-04-2013, 05:23 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jun 2013
Posts: 9
Thanks: 1
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
bump

bump, anyone out there know anything?? thank you!

btw... i checked all the fuses and they all seem fine.
surfmotion is offline  
post #3 of 6 Old 01-17-2014, 07:52 AM
Member
 
Join Date: Nov 2012
Location: Charlotte
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
same problem...
FAAST is offline  
post #4 of 6 Old 01-17-2014, 08:26 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jun 2013
Posts: 9
Thanks: 1
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
FAAST , Let me know if you ever find any answers. Posted this a while ago and no one on the forum has replied (obviously)...My local mechanic told me awhile back that he thinks that if I get the IC re-programmed to the truck that it could possibly fix the nuisance. Haven't done it yet because I feel like there could be a simple (and free) way for me to fix it myself... I have just gotten used to detaching my faceplate when I Turn off the truck.
surfmotion is offline  
post #5 of 6 Old 11-12-2015, 05:41 PM
Powerstroke.org Rookie
 
Join Date: Jun 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Have you found a fix for this problem?

I'm having the same issue
Liquidrider12 is offline  
post #6 of 6 Old 11-12-2015, 05:50 PM
,,,,,,,,,,,,,,,,,,,,,,,,,
 
ZMANN's Avatar
 
Join Date: Feb 2008
Posts: 17,273
Thanks: 820
Thanked 881 Times in 850 Posts
Mentioned: 106 Post(s)
Quoted: 1176 Post(s)
Feedback Score: 0 reviews
this thread is old why don't you elaborate or start your own thread
we are lucky to have Circuit Board Medics on here and they can help you
ZMANN is offline  
Sponsored Links
Advertisement
 
Reply

Tags
electrical issues , instrument cluster , interior lights , problems

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome