Rear Tail Light and License Plate Lights not working - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 07-13-2013, 08:30 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Exclamation Rear Tail Light and License Plate Lights not working

Hey everyone. I have a 2006 Ford F250 6.0 Powerstroke and currently have no tail lights or license plate lights. I have brake lights, turn signals, back up lights, and even have trailer lights. I've checked all of my fuses with a volt meter multiple times and everything is reading 12 volts on both sides of the fuses. I'm hoping someone can point me in somewhat of a right direction to see what I should check next. Are there any relays that I should check and if so which ones? Thank you in advance!!!! Any help is much appreciated.
tmanrose2007 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 09-24-2013, 07:39 PM
Premium Member
 
capcalvin's Avatar
 
Join Date: Nov 2008
Location: NWI
Posts: 909
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Ever get it fixed? Having the same issue.

'03 F350 6.0 CC dually lariat 4x4
Autometer gauges:
Pyro, boost, fuel pressure
Edge insight cts
Bulletproof EGR cooler (Blocked off)
Oil cooler rebuilt
Coolant filter
Delvac EC-1 ELC
Exhaust: MBRP 4" cat back with delete pipe
SCTx3 Tunes by Innovative and Gearhead
Swamps 58v FICM
High idle mod
SRW front wheel conversion
ARP head studs

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

capcalvin is offline  
post #3 of 6 Old 09-25-2013, 01:55 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Yeah I did. After checking everything with a volt meter I lowered the spare tire down to look at the harness. At the harness I found a wire that wasn't completely separated but it had a nice gash in it and sure enough that was it. Everything has been fine since then.
tmanrose2007 is offline  
post #4 of 6 Old 09-25-2013, 05:59 AM
Premium Member
 
capcalvin's Avatar
 
Join Date: Nov 2008
Location: NWI
Posts: 909
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Thanks! I'll check it out today.

'03 F350 6.0 CC dually lariat 4x4
Autometer gauges:
Pyro, boost, fuel pressure
Edge insight cts
Bulletproof EGR cooler (Blocked off)
Oil cooler rebuilt
Coolant filter
Delvac EC-1 ELC
Exhaust: MBRP 4" cat back with delete pipe
SCTx3 Tunes by Innovative and Gearhead
Swamps 58v FICM
High idle mod
SRW front wheel conversion
ARP head studs

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

capcalvin is offline  
post #5 of 6 Old 09-25-2013, 06:01 PM
Premium Member
 
capcalvin's Avatar
 
Join Date: Nov 2008
Location: NWI
Posts: 909
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Fixed it! Same scenario. Wire was smashed right at the plug where it splits off of the main harness.

'03 F350 6.0 CC dually lariat 4x4
Autometer gauges:
Pyro, boost, fuel pressure
Edge insight cts
Bulletproof EGR cooler (Blocked off)
Oil cooler rebuilt
Coolant filter
Delvac EC-1 ELC
Exhaust: MBRP 4" cat back with delete pipe
SCTx3 Tunes by Innovative and Gearhead
Swamps 58v FICM
High idle mod
SRW front wheel conversion
ARP head studs

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

capcalvin is offline  
post #6 of 6 Old 11-10-2013, 06:15 PM
Powerstroke.org Sponsor
 
OCVeloMan's Avatar
 
Join Date: Aug 2010
Location: Orange, CA
Posts: 2,795
Thanks: 76
Thanked 177 Times in 158 Posts
Mentioned: 16 Post(s)
Quoted: 147 Post(s)
Garage
Feedback Score: 2 reviews
investigating the same issue, Had bumpers made for the truck and everything under the rear was messed with. My instrument cluster lights are now out too....


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

OCVeloMan is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome