possible problem with my edge - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-25-2013, 04:03 AM
Compression Ignition Addict
 

Join Date: Nov 2012
Posts: 162
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
possible problem with my edge

So, Ive got a 2004 F250 that was being driven weekly by my wife because im on a deployment for another couple months.

So my buddy took it on a 300 mile trip with no problems. it sat a week once he brought it back then the batteries died. My wife charged the batteries and started it, drove it. the batteries we over 12.5 when it was parked. Its got a new alternator and 1 new battery. she went to start it again a few days after being driven and boom- 9.5v she said my EDGE juice with attitude CTS screen was staying on when she tried to start it. I havent every seen a parasitic draw happen out of nowhere before. I know my info is limited, but i can only FB my wife and shes no mechanic.

just wondering if anyone has had a problem with the tuners causing a draw?

Last edited by mustangmike6996; 05-25-2013 at 04:53 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-25-2013, 04:31 AM
Compression Ignition Addict
 

Join Date: Apr 2009
Location: Kitty Hawk
Posts: 229
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
The other battery is bad which will bring down the good battery

Replace the other battery with the same as the replaced one
Reply With Quote Quick reply to this message
  #3  
Old 05-25-2013, 04:54 AM
Compression Ignition Addict
 

Join Date: Nov 2012
Posts: 162
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I was going to have her get it charged and have the batteries re-tested. The alternator **** out 2 days before i shipped out and i replaced it. at the time, both batteries were tested and were good. but i understand that **** happens lol.
Reply With Quote Quick reply to this message
  #4  
Old 05-27-2013, 03:59 AM
Compression Ignition Addict
 

Join Date: Nov 2012
Posts: 162
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
the truck is still on the charger... ill let you all know how the other battery tests when the truck will start
Reply With Quote Quick reply to this message
  #5  
Old 06-04-2013, 03:03 PM
Compression Ignition Addict
 

Join Date: Nov 2012
Posts: 162
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well, my passenger battery was bad. The driver battery was on the tender for 4 days. It started at 3.7 and is now at 2.8...... So I'm pretty sure there's a big drain somewhere. I won't be home for 2 more months so my wife will install the new passenger battery and disconnect the driver side until I get home to troubleshoot it.
Reply With Quote Quick reply to this message
  #6  
Old 06-13-2013, 03:53 AM
Compression Ignition Addict
 

Join Date: Nov 2012
Posts: 162
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Anyone have any recommendations for the time being?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:45 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors