Instrument lights are not working. - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 07-31-2012, 02:58 PM Thread Starter Rookie
Join Date: Mar 2012
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Instrument lights are not working.

Hello! I am new here and have recently bought a 2005 F350 club cab 6.0 diesel.

I can not figure out how to turn on the Lights to illuminate the gages ( fuel, Temp. etc) I checked the fuses shown in the operators manual and they check out good. I tried to check the bulbs but have no idea on how to get to them. On older vehicles one could reach in from under the dash, but not with this one.
Can anyone here give me some advise on how to proceed and get my instrument lights working? All other lights work OK.Maybe there is another test I can do other the changing the light bulbs in the Instrument cluster.
How would I get access to them.
Would appreciate any advise you could give me.
snowflake28 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome