radio display inop but radio works - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-03-2012, 03:19 PM
Member
 

Join Date: Jun 2011
Location: Oak Grove, Missouri
Posts: 88
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
radio display inop but radio works

The backlight for the radio quit working but still funtions properly. I can turn on/off change stations and all presets still work, just the display is dead. No clock, or anything. The only lights i get are two little led lights from the CD player. Is there some fuse somewhere to check or is the radio needing replacing? Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-03-2012, 03:32 PM
Chapter Director
 

Join Date: Feb 2006
Location: Sacramento
Posts: 7,579
Thanks: 8
Thanked 45 Times in 38 Posts
Feedback Score: 3 reviews
I think it's just the display is dead. If it were a fuse, the radio wouldn't get any power at all.
Reply With Quote Quick reply to this message
  #3  
Old 05-03-2012, 03:45 PM
Compression Ignition Addict
 

Join Date: Feb 2008
Posts: 6,221
Thanks: 32
Thanked 55 Times in 53 Posts
Feedback Score: 0 reviews
I have My old one from last years upgrade
and it's in good shape and in shipping mode ( most folks don't know it has that option ,,lol)
$75 pay pal and + shipping via ups signature required .
otherwise if yours toast and want , upgrade? and spend a couple $100 more ??

I have suggestions
Reply With Quote Quick reply to this message
  #4  
Old 05-03-2012, 03:47 PM
Compression Ignition Addict
 

Join Date: Jul 2011
Location: Boca Raton, Florida
Posts: 1,537
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 4 reviews
I have a problem similar to this but it's the other way around. My radio is getting power to it but it will not turn on. All the lights on the buttons light up and when you press the power button the screen comes on shows the ford logo and time and then shuts off. Also none of my windows work. This seems to be a delayed accessory problem but I checked all the fuses for radio, windows, and delayed accessory and they are all good. How would I go about checking the big cube looking relays? I think that could be the culprit


Sent from my Autoguide iPhone app
Reply With Quote Quick reply to this message
  #5  
Old 05-03-2012, 03:48 PM
Chapter Director
 

Join Date: Feb 2006
Location: Sacramento
Posts: 7,579
Thanks: 8
Thanked 45 Times in 38 Posts
Feedback Score: 3 reviews
unless his truck's an 03-04
Reply With Quote Quick reply to this message
  #6  
Old 05-03-2012, 04:52 PM
Member
 

Join Date: Jun 2011
Location: Oak Grove, Missouri
Posts: 88
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have an 03..... I checked the only radio fuse which was of course good. Man you dont realise how often you look at the clock until you dont have the clock!!! I going to check at a local salvage yard and see if they have any radios still in workin order. Thanks for your replys!!!
Reply With Quote Quick reply to this message
  #7  
Old 05-03-2012, 04:55 PM
Member
 

Join Date: Jun 2011
Location: Oak Grove, Missouri
Posts: 88
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by ZMANN View Post
I have My old one from last years upgrade
and it's in good shape and in shipping mode ( most folks don't know it has that option ,,lol)
$75 pay pal and + shipping via ups signature required .
otherwise if yours toast and want , upgrade? and spend a couple $100 more ??

I have suggestions
Thanks for the offer!!! I will check the local salvage yard and see if they can help and if not I will get hold of you. Will the 03 and 06 radio be compatible?
Reply With Quote Quick reply to this message
  #8  
Old 05-03-2012, 06:44 PM
Compression Ignition Addict
 

Join Date: Oct 2007
Location: Southwest,Ga
Posts: 498
Thanks: 3
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It's a cracked solder joint on the back of the display board more than likely.I have fixed a lot of the on expeditions and f150's never seen it happen on an F250.
all you need to do is pull the radio,take of face plate,resolder all solder jonts and test
Reply With Quote Quick reply to this message
  #9  
Old 05-03-2012, 08:16 PM
Compression Ignition Addict
 

Join Date: Feb 2008
Posts: 6,221
Thanks: 32
Thanked 55 Times in 53 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by travelin_farmer View Post
Thanks for the offer!!! I will check the local salvage yard and see if they can help and if not I will get hold of you. Will the 03 and 06 radio be compatible?
I don't think so ,, sorry I didn't notice the year if it was posted ?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:29 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors