No radio windows gauges or interior lights - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-07-2012, 06:50 AM
Member
 

Join Date: Apr 2012
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No radio windows gauges or interior lights

My 06.5 f350 6.0 has had an eletronic problem for about 2weeks this problem just happened out of no where i had no symptons before. I had a couple bulbs on the back of instrument cluster that were bad so i changed them and drove it to and from work then I let the ole lady drive it and then everything just went out and ive checked all the fuses and #41 is not getting any power but is not blown and all electronics are stock, I have no radio but the lights and clock, and itll let me eject the cd, the door ajar and reading lights dont work, the windows dont work but the door locks do, the auto headlights do not work either, but when you manually turn them on the headlights work and the entire dash lights up like it should even the radio, None of the gauges turn on move or anything when the key is turned on or truck is running, the odometer isnt working the only lights that show up on the instrument pannel is the battery, air bag light, the turn signals and high beams. also the wipers do work dont know if this makes a difference
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-07-2012, 07:53 AM
Suck, Squish, Bang, Blow!




 

Join Date: May 2011
Location: North Bend, WA
Posts: 6,467
Thanks: 184
Thanked 176 Times in 144 Posts
Feedback Score: 0 reviews
Sounds like you had a main fuse blow. Check the fuses and relays under the hood. Might have had a main ground wire come off somewhere as well. Good Luck.
Reply With Quote Quick reply to this message
  #3  
Old 04-07-2012, 12:10 PM
Member
 

Join Date: Apr 2012
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I've swapped relays and checked all the the fuses up on the driver side fender and all are good are there any inline fuses that are not on the box and where are the grounds that tend to be a major problem.... and the gem is that the same as the body module and what about the instrument cluster do you believe any of these went out or unlikley since they are getting some power
Reply With Quote Quick reply to this message
  #4  
Old 04-08-2012, 01:40 PM
Powerstroke.org Rookie
 

Join Date: Oct 2008
Location: Carson City
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
How bright are the headlights when you turn them on. I just had basically the same thing happen to me , same symptoms, and I think it is my alternator as I just installed new batteries three days ago and now they're dead.
Reply With Quote Quick reply to this message
  #5  
Old 04-08-2012, 05:58 PM
Powerstroke.org Fanatic
 

Join Date: Jun 2010
Posts: 121
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Re check all of them under the dash mine blew 2 and was doing the same thing can't remember which ones though
Reply With Quote Quick reply to this message
  #6  
Old 04-09-2012, 02:05 PM
Member
 

Join Date: Apr 2012
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I will recheck again i took and tested all for continuity but will check again i could have missed one if you think of the fuse number that where bad let me know... and the lights seem to be bright enough the batteries where charging at like 13.4 and the batteries where just replaced a month ago
Reply With Quote Quick reply to this message
  #7  
Old 04-09-2012, 02:58 PM
Powerstroke.org Rookie
 

Join Date: Apr 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Hey, love to know what you find. This same exact thing happened to me this morning when I was getting on the to make a 6 hour drive home. UGG!
Reply With Quote Quick reply to this message
  #8  
Old 04-10-2012, 12:59 PM
Member
 

Join Date: Apr 2012
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
will do as soon as i find the problem and let me know if you do first
Reply With Quote Quick reply to this message
  #9  
Old 04-17-2012, 06:18 AM
Compression Ignition Addict
 

Join Date: Jul 2011
Location: Boca Raton, Florida
Posts: 1,537
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 4 reviews
I also have a very similar problem. I cut the wires to my under hood light to splice in an LED light strip. When I got back in the truck I started it and my radio wouldn't come on. Then I tried to open the windows and non of them work. Its a very strange problem because I am getting main power to the radio because the dash lights on the radio all come on when I turn on the headlights and the time shows and the ford logo comes up when I press the power button (I have factory nav). On the driver window switch I'm not getting any power because the switch does not illuminate when I turn the headlights on but the door locks work and the power mirror works, but none of the backlights are on? I haven't really had a change to check for power or check any fuses but I'll give updates if I find anything.
Reply With Quote Quick reply to this message
  #10  
Old 04-19-2012, 03:33 PM
Member
 

Join Date: Apr 2012
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It ended up being my cluster that was bad bought one off ebay for $42 and installed it the odometer is registered in the cluster... but on the bad news now nothing turns off when i open the door so everything stays on till the 10min relay turns off so that means i have door ajar problem now i have to track down.. any help with this would be greatly appreciated
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:24 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors