Fuse 17 Running lights and gauge lamps - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 11-03-2011, 09:35 PM Thread Starter
Powerstroke.org Rookie
Join Date: Nov 2011
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Fuse 17 Running lights and gauge lamps

Hey out there

2005 F350 6.0

I just installed a stereo head unit and Banks 6 gun. Pulled the dash a few times and when the project was complete I realized I had no lamps on my dash instruments, speedo is not operational, and the running lights dont work. I checked all fuses and 17 (10 amp) was blown. Replaced the fuse and the lights worked for a period, began to flicker, and the fuse blew again. I pulled the dash and made sure all the wiring harness connections were good to the dash. All other gauges work and the dimmer switch still activated my dome light.

Where do I go from here???

dak4akx2000 is offline  
Sponsored Links
post #2 of 2 Old 11-04-2011, 05:06 AM
Compression Ignition Addict
Davey~do's Avatar
Join Date: Nov 2008
Location: Lumberton, TX
Posts: 855
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 2 Times in 1 Post
Feedback Score: 0 reviews
Did you happen to pinch one of your ground wires perhaps?

2.5" Level, Amp Steps
Davey~do is offline  
Sponsored Links

2005 6.0 electrical, gauge lamps, speedo, speedometer

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome