tow/haul light not working - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 11-02-2011, 08:57 PM Thread Starter Rookie
Join Date: Nov 2011
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
tow/haul light not working

I have a 2004 f350 diesel that I just bought, vehicle works great except the tow/haul light in the instrument cluster does not come on when put into tow/haul mode. The tow/haul mode works as it should, I have checked the light via the instrument cluster diagnostic mode and its fine, checked all the wires as far as I could follow them and they appear fine. Does anyone have any other ideas for me to investigate, could it be possible that my pcm is not programmed properly?
Ruban is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome