Charging questions - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 03-09-2011, 02:39 PM Thread Starter Rookie
Join Date: Jan 2011
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Charging questions

I have a few questions about the 6.0L charging system First of all I beleave I have weak batteries they both tested seperately at 12.2v load tested them to 325amps Half the cold cranking amps. they dropped to 10.25v. I had some starting issues over the weekend that threw me for a loop. The truck would not start but cranked good ( normal ). I read somewhere that if you had week batteries for some reason all your power would go to the starter and not the lift pump. If this is true it would explain why my fuel bowl was half empty. Second after 3 of 4 crank attempts without a start I would get the P2614 cam postion sensor fault. When I got it started I cleared the code and it stayed off and the truck ran good. last is my alternator with the truck running my batteries read between 13.1 and 13.3 this is within spec but seems low its at 12.0 volts until the glow plugs shut off could this be caused because the batteries are weak or the alternator is going out as well. I have a 2005 F250 that i got a year ago it has motorcraft batteries in it. not sure if they are original or the previous owner replaced them with OEM. The truck has been starting for two days now but cranks a little longer than normal about 5 to 7 seconds before it starts. I don,t want to replace parts that are not in need of change so any ideas of where to start. Any help would be greatly appriciated.
111aj is offline  
Sponsored Links
post #2 of 2 Old 03-09-2011, 04:01 PM Rookie
Join Date: Mar 2011
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Wish I had good news, but I have an 06 F250 and have had to replace the batteries yearly or sooner for who knows what reason. They tell me I need to idle at 1200 rpm to keep them charging, WRONG! Anyway sounds like new batteries might be in your future. Good Luck.
jhawkjoel is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome