Brake light issue - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-08-2011, 07:41 PM Thread Starter
Join Date: Mar 2010
Posts: 50
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Brake light issue

Hi guys, I have a 2005 1 ton xlt. I plugged a trailer in and blew a fuze, i believe that is when it happened i noticed the problem after i towed with it. i replaced the fuse but now i have no rear brake lights. My cargo light lights up and blinks, should it do this? i have can not remember it ever blinking with the blinker. or coming on with the brake lights. When i have the turn signal on and hit the brakes the turn signals stop working. i have good bulbs the relays under the hood are clicking and i have power to both trailer plug ins.
If anyone has any ideas what might be wrong please let me know. i am not an electrician so i do not know all the in's and out and if someone could put me in the right direction that would be awesome.
lilrams09 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome