HID Flicker Help..... - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-13-2011, 09:12 PM
Member
 

Join Date: Apr 2010
Location: Boulder County
Posts: 67
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
HID Flicker Help.....

So I have a 2004 F250 lariat... about a year and half ago, I put HID (10000K) in the headlights and HID (10000K) in the fog lights. Everything worked fine on power up and never needed a relay on either set.

About a week ago the drivers side headlight ballast burns out.... i figure while I am changing the ballast, I want new bulbs. I switched to 6000K headlights and kept the fogs at 10000k. Put everything back together and now the drivers side headlight bulb flickers.... fogs still work fine.

I read about flickering HIDs so I put a relay on the system and it still flickers. I changed the bulb (thinking it was a bad bulb) and it still flickers... I also changed the ballast (again, thinking it was another bad ballast) and it still flickers.

I am getting frustrated.... anyone have any ideas on how to fix this? Thanks for the help!

by the way, its a Xentec light system.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-14-2011, 11:53 AM
Powerstroke.org Fanatic
 

Join Date: Nov 2010
Posts: 94
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Check all of your grounds.
Does it flicker with the truck not moving ? How about with the engine off ?
Reply With Quote Quick reply to this message
  #3  
Old 02-14-2011, 12:04 PM
<-Day Of Fail now SOLD

 

Join Date: May 2008
Location: Japan
Posts: 3,393
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
yes it kind of sounds like a bad ground.
Reply With Quote Quick reply to this message
  #4  
Old 02-14-2011, 02:28 PM
Member
 

Join Date: Apr 2010
Location: Boulder County
Posts: 67
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
all the grounds seem to be good from what I can tell....

what confuses me is I switched the non-flickering set with the flickering side and it still flickered on the drivers side. The passenger works fine with both kits. When I switch it all back, its still just the drivers side that flickers. It makes me think a bad ground too, but somewhere on the truck side as opposed to the HID kit side... any ideas...?

oh, and it seems to only flicker when I am stopped, (truck running or off).... It may have just been harder for me to see it flickering when I was moving.....
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:58 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors