Speedo?? Sometimes It Works Sometimes not so much!!! - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-30-2011, 06:01 PM
Powerstroke.org Rookie
 

Join Date: Apr 2009
Location: Buena Park
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to socalocman03 Send a message via Yahoo to socalocman03
Speedo?? Sometimes It Works Sometimes not so much!!!

Hope all have had a great relaxing weekend. You need to be nice and refreshed for your long work week so you can make that money, pay your taxes like good Americans, then watch our government waste it!!!! Yea!!! Makes a man Happy to pay Taxes, Doesn't it?? lol

Anyway, I have a speedo problem, I've read and actually the truck has been in the shop for another unrelated problem at which time they do whatever it is they do to asses the situation with the gauge. However, this is my situation...All works fine for months on end keeps correct MPH, Starts and Stops with the truck etc etc....Then out a the blue it will Peg out completely to the far right (actually puts it at the bottom via a right hand sweep) then drop back to about half way and just sorta float there, start to slowly move back and forth like its doing the wave at a pro ball game and all this regardless of my speed. Then like a light switch is thrown it will start working perfectly again?? WTH??? Either work or don't work ya stupid stupid gauge!!! Sheesh!!! It's a 2006 F-550 Xlt 6.0 Super Duty with just under 50k on the odometer. Not sure what can be done but it really is a PIA not knowing my speed cause I tend to be a bit of a lead foot and it sorta comes in handy, that there speedometer thingy does!!! I'd take it in to Ford but I can't afford to have the truck off the road for a day or two for them to do diagnostics on the truck only to tell me they can't duplicate the problem. Any suggestions would be great.

Les

Last edited by socalocman03; 01-30-2011 at 06:05 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-30-2011, 06:14 PM
Compression Ignition Addict
 

Join Date: Aug 2009
Location: Eastern KY
Posts: 374
Thanks: 5
Thanked 0 Times in 0 Posts
Feedback Score: 5 reviews
I had a similar on my 00'. Replaced the speed sensor on the rear axle and no more floating speedo. Hope this is your problem, as it was an easy fix.
Reply With Quote Quick reply to this message
  #3  
Old 01-30-2011, 06:15 PM
Compression Ignition Addict
 

Join Date: Aug 2009
Location: Eastern KY
Posts: 374
Thanks: 5
Thanked 0 Times in 0 Posts
Feedback Score: 5 reviews
By the way, I have also heard the speed sensor is prone to coming loose and getting mucked up. Yours might just need a good cleaning and tightened down?
Reply With Quote Quick reply to this message
  #4  
Old 01-30-2011, 08:35 PM
Powerstroke.org Rookie
 

Join Date: Apr 2009
Location: Buena Park
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to socalocman03 Send a message via Yahoo to socalocman03
thanks for your reply, I'll need to check the sensor out. Any Ideas as to how one can go about testing the sensor or detect whether it is the culprit causing the problem? Would the sensor work perfectly some days and not work others?

Thanks again for your help

Les
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:11 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors