DIY High Idle install problem! - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-27-2010, 12:43 PM
Compression Ignition Addict
 

Join Date: Nov 2010
Posts: 180
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
DIY High Idle install problem!

Thanks to ssamsom so far for the help. I thought I better post a thread separate from the other one. I followed the directions for the 07 install to a T and cant figure this out. I do not have power to any of my upfitter wires, but the lights on all switches come on when you flip them. What is going on? Is there a master fuse for the upfitter? The only thing I can find in the manual is a relay, but other fuses. I am lost!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-27-2010, 03:19 PM
Compression Ignition Addict
 

Join Date: Sep 2010
Posts: 237
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Subscribing
Reply With Quote Quick reply to this message
  #3  
Old 11-27-2010, 04:15 PM
Compression Ignition Addict
 

Join Date: Mar 2008
Location: Santa Rosa, CA
Posts: 1,347
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Here are the fuse #'s in the dashboard fusebox for the upfitters:

#115 - 20amp - Upfitter Control
#108 - 30amp - Upfitter #1
#109 - 30amp - Upfitter #2
#3 --- 10amp - Upfitter #3
#5 --- 10amp - Upfitter #4

And Relay #305 - Upfitter Control


This is for my 2005, but it should be the same for 2006 and 2007 also
They are all listed in the owners manual.

Last edited by GregsSD; 11-27-2010 at 04:18 PM.
Reply With Quote Quick reply to this message
  #4  
Old 11-27-2010, 05:04 PM
Compression Ignition Addict
 

Join Date: Nov 2010
Posts: 180
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok, all fuses are good. So now I have to ask a question. Does power route from the fuse to switch to the relay then to the wire? Because all my fuses are good? I can replace the relay if that is the culprit, but I still have no power to the wires themselves. That is what has me stumped.
Reply With Quote Quick reply to this message
  #5  
Old 11-27-2010, 10:15 PM
Compression Ignition Addict
 

Join Date: Mar 2008
Location: Santa Rosa, CA
Posts: 1,347
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
There are 4 relays for the upfitters above your glovebox, I think there is also another fuse there too.

Just pop the side tabs on your glovebox so you can swing it down out of the way, then look up in the opening to see the relays.
Reply With Quote Quick reply to this message
  #6  
Old 11-28-2010, 05:06 AM
Compression Ignition Addict
 

Join Date: Nov 2010
Posts: 180
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by GregsSD View Post
There are 4 relays for the upfitters above your glovebox, I think there is also another fuse there too.

Just pop the side tabs on your glovebox so you can swing it down out of the way, then look up in the opening to see the relays.
Thank you, will take a look in just a little bit.
Reply With Quote Quick reply to this message
  #7  
Old 11-28-2010, 06:25 AM
Compression Ignition Addict
 

Join Date: Nov 2010
Posts: 180
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok I have the relays and it looks like there is just one 5amp fuse under the glove box. I need to get mirror, they wont pull out. I am really sorry, but this is stupid and I feel like an idiot. Thank you for being patient with me.
Reply With Quote Quick reply to this message
  #8  
Old 11-28-2010, 08:08 AM
Compression Ignition Addict
 

Join Date: Nov 2010
Posts: 180
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Guys, I am seriously lost. I ran a jumper wire from a constant 12v source in the fuse panel to both the pto/orange and bcp wires and she revs up fine with either wire. I guess I can install another switch independent of my already installed upfitters and use it that way. It just ticks me off that I have no power to my upfitters and cant figure out why. Lights all work on them, fuses are all good. Off the parts house to get a switch.
Reply With Quote Quick reply to this message
  #9  
Old 11-28-2010, 08:19 AM
Compression Ignition Addict
 

Join Date: Sep 2010
Posts: 237
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Sorry to hear that man, I guess you could try to put the switch somewhat out of view so that if you get the upfitters working one day you wont have a gaping hole in the dash of that beautiful KR. Good luck with the install
Reply With Quote Quick reply to this message
  #10  
Old 11-28-2010, 08:24 AM
Compression Ignition Addict
 

Join Date: Nov 2010
Posts: 180
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks sam, I have a place picked out for the switch. Next time I go to the dealer I will have the tech get them working. Its just irritating. Thank you for the advice and patience.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:55 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors