blowing 20 amp ignition switch maxi fuse - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 10-16-2010, 03:14 PM Thread Starter Rookie
Join Date: Apr 2010
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
blowing 20 amp ignition switch maxi fuse

04 F350 6.0 Just did my oil cooler replacement got it back together started right up, get on the road and blew a tubo hose off. Turn the truck around get to house turn it off and fix hose (clamp was not at end of hose but looked like it belonged there till I looked closer). Now I am blowing the 20 amp maxi fuse for the ignition switch location 116 in the panel. I cant find any wires in the engine compartment frayed or grounded. Pulled the fuse panel a wire that runs from behind the 101, 102, 107 maxi fuse is burnt copper showing for about 4 inches and a wire running from the block at the steering column Im guessing is for the ignition switch is burnt all the way back into harness I think the are blue and orange. Is there a wiring diagram somewhere I can look at. Any help would be welcome.
thunter95 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome