Info center died on me. - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

LinkBack Thread Tools Display Modes
post #1 of 2 Old 10-13-2010, 11:41 AM Thread Starter
Compression Ignition Addict
STANG302's Avatar
Join Date: Jun 2007
Location: Osceola, WI
Posts: 231
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Info center died on me.

It started probably about a year ago when my compas started acting up. But everything else seemed to work fine for a while. Till a week ago the entire thing stoped working. Is this a common problem? If so what fixes it?

04' F350 King Ranch
4' MBRP Turbo back
EGR valve delete spool
B&W Goosneck
Osceola Party Rental
STANG302 is offline  
post #2 of 2 Old 10-13-2010, 12:00 PM
Super Moderator

SuperCrutyPS's Avatar
Join Date: Jul 2008
Location: Orangevale, CA
Posts: 15,423
Thanks: 83
Thanked 507 Times in 491 Posts
Mentioned: 5 Post(s)
Quoted: 278 Post(s)
Feedback Score: 0 reviews
Take a look at this thread to see if it's what's happening to you

Overhead computer Fix - Easy and it works

Owner | Operator: Darryl
My Truck Garage: Ol' Guy
Tow Toy Garage : Pilgrim International 31RE3SLF5
United States Navy - IC2 - '76-'80
SuperCrutyPS is online now  

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome