no trailer breaks - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 09-17-2010, 02:00 PM Thread Starter
Compression Ignition Addict
mattdoxa's Avatar
Join Date: Jan 2009
Location: congers NY
Posts: 1,030
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
no trailer breaks

my 06 6.0 doesnt have trailer breaks when the trailer is plugged in and i hit the built in break controler it says trailer disconnected. my dad has the same plug on his 01 and 07 with the same trailer the breaks work.. i hooked a test light up to the prong in the plug on the truck and it lights up but still no breaks.. any suggestions?
mattdoxa is online now  
Sponsored Links
post #2 of 2 Old 09-17-2010, 03:25 PM
Serving Our Country!
JSchuricht's Avatar
Join Date: Aug 2007
Location: Manor, TX
Posts: 2,962
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 23 Times in 22 Posts
Feedback Score: 2 reviews
What plug are you using, 7 pin flat/round, 6 pin, 4 pin? You need to verify the ground is good from the truck to the trailer and that the brake power wire is supplying ~12v.

JSchuricht is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome