amp/sub help! - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-28-2010, 03:01 PM
Compression Ignition Addict
 

Join Date: Aug 2010
Location: Charleston, SC
Posts: 395
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
amp/sub help!

i have an arc 500.1 amp and i arc 10 sub. The amp has incredible numbers on it. I installed the system in my truck and is sounded great for about a week or so. Well just the other day the sub started playing at just low volume and when i turn it up it quits. The amp with blink red and green. But i have hook another small 12 up to it and it plays, i also hooked another arc 12 up to in and it had the same problem with it cutting off. I know a good bit about systems but i dont know the tech. stuff. I dont think either one is messed up because my last time driving it, it was working great then i cranked it the next day and thats when the problem started. Both are brand new. Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-28-2010, 03:28 PM
Compression Ignition Addict
 

Join Date: Dec 2006
Location: Lockport IL
Posts: 4,297
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 7 reviews
Send a message via AIM to dereku
check your grounds of redo them that always worked for me
Reply With Quote Quick reply to this message
  #3  
Old 09-19-2010, 03:37 PM
Powerstroke.org Fanatic
 

Join Date: Mar 2010
Location: Grand Junction, CO
Posts: 131
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
What size of Amp kit are you running? Sounds like you are running too small of cable and your amp is just overheating.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:19 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors