Radio help....please asap - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-24-2010, 06:05 PM
Firefighter Member
 

Join Date: Dec 2008
Location: Dunnellon, FL
Posts: 748
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Radio help....please asap

so i just installed a radio/dvd player. Well the faceplate stopped working and found out the ribon ripped...soo in the mean time till that comes in I went to plug the stock one in. Plugged it in and turned the truck on.....nothing. can hit eject cd and it will eject....nothing else. Turn my lights no and its lights come on and nothing else happens....any help would be nice. Thanks in advanced.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-24-2010, 06:08 PM
Premium Member
 

Join Date: Dec 2009
Location: Ohio
Posts: 2,248
Thanks: 2
Thanked 3 Times in 3 Posts
Feedback Score: 1 reviews
Sounds silly but did you plug all of the plugs and the antenna in ? If so , did you pop a fuse ?
Reply With Quote Quick reply to this message
  #3  
Old 08-24-2010, 06:27 PM
Firefighter Member
 

Join Date: Dec 2008
Location: Dunnellon, FL
Posts: 748
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
their is only one factory plug....same one when I took it out....and all fuses look good....i'm completely stumped....
Reply With Quote Quick reply to this message
  #4  
Old 08-24-2010, 06:53 PM
Premium Member
 

Join Date: Dec 2009
Location: Ohio
Posts: 2,248
Thanks: 2
Thanked 3 Times in 3 Posts
Feedback Score: 1 reviews
Hmmmm , me too . Does the cigarette lighter work ?
Reply With Quote Quick reply to this message
  #5  
Old 08-24-2010, 06:58 PM
Premium Member
 

Join Date: Dec 2009
Location: Ohio
Posts: 2,248
Thanks: 2
Thanked 3 Times in 3 Posts
Feedback Score: 1 reviews
I would say unplug it an look to see if any of the terminals got bent or shoved in . Also are you looking at or testing your fuses ? You cant always see a bad one .
Reply With Quote Quick reply to this message
  #6  
Old 08-24-2010, 06:59 PM
Compression Ignition Addict
 

Join Date: Apr 2007
Posts: 3,366
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
check to make sure antenna is fully seated
Reply With Quote Quick reply to this message
  #7  
Old 08-24-2010, 07:20 PM
Firefighter Member
 

Join Date: Dec 2008
Location: Dunnellon, FL
Posts: 748
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
lighter plug works....looking at fuses...so I guess i'll get some new ones tomorrow to rule that out. atnea all the way in....thanks for all the help. Any input is useful and thanks again.
Reply With Quote Quick reply to this message
  #8  
Old 08-26-2010, 11:55 AM
Firefighter Member
 

Join Date: Dec 2008
Location: Dunnellon, FL
Posts: 748
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
just to update and let anyone know how to fix this.....got new fuses...andd nothing......started going fuse by fuse on the whole panel. #42....Delay Accessory...thats the one that lets you radio turn on. Blown 15 mini fuse....works like a charm now. Hope this will help someone else out.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:48 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors