03 F250 6.0 sudden Electric Problem!!!! Fuel gauge, outside temp and airbag - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 04-15-2010, 08:03 PM Thread Starter
Powerstroke.org Rookie
Join Date: Jun 2008
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
03 F250 6.0 sudden Electric Problem!!!! Fuel gauge, outside temp and airbag

I have a problem that seems to have started when I plugged in a trailer that was incorrectly wired into my 03 F250 6.0. The Fuel gauge went to zero and has stayed there ever since, the airbag light is on and the overhead outside temp is off by at least 20 degrees. Also, when you lock the doors with the fob, the horn does not beep any more although the horn works when you press it normally.

I have replaced a blown fuse, unhooked the batteries to try to reset things, but to no avail. I checked voltage at the 12v accessory plug and it reads 13.2 volts with the engine running. Anyone have any ideas???
jzuccone is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome