Air Vents not blowing??? - Ford Powerstroke Diesel Forum

6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 03-27-2010, 02:36 PM Thread Starter
Member
 
jbobrik's Avatar
 
Join Date: Feb 2010
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Air Vents not blowing???

I have a 05 6.0 and my air vents just stopped working. The only one it is blowing out of is the Defrost. I have the electronic control module in the truck, i've had trouble with this unit in the past but i changed a fuse an haven't had any troubles like this before. When i push the buttons on the module to switch to blow air on feet or face, i can hear it act like its working but the air doesn't change off of defrost mode. My other problem was the unit just wasn't working but it's fine now. Any ideas, thanks guys
jbobrik is offline  
post #2 of 4 Old 03-31-2010, 06:58 PM
Powerstroke.org Fanatic
 
Join Date: Nov 2007
Posts: 100
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I have the exact same problem. It's on and off though, not all the time.

2007 F-250 Lariat Outlaw
Donahoe 4.5" lift, Icon TEI brackets,Fox Racing 2'Reservior shocks,Amp Research steps,KMC 20" Rockstars,Mickey Thompson ATZ 35x13.5,Accufab intake elbow,MBRP 4" catless straight pipe,SCT Xcal2 from Innovative Diesel running xtreme street for 2 years, Autometer gauges
Blacked Out Outlaw is offline  
post #3 of 4 Old 03-31-2010, 07:13 PM
Compression Ignition Addict
 
baddkarmaracing's Avatar
 
Join Date: Jul 2008
Location: harlingen tx
Posts: 1,143
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Feedback Score: 0 reviews
you have a vacuum leak somewhere the doors for the ac work off vacuum and ifs theres no vacuum they cant move i would check the lines at the hubs and see if they are cracked or anything

2008 F250 6.4 CC SB Fx4
Gearhead tunes, flopro exhaust,AFe intake
baddkarmaracing is offline  
post #4 of 4 Old 05-14-2010, 06:00 PM
Powerstroke.org Fanatic
 
MeltonUnlimited's Avatar
 
Join Date: Mar 2010
Location: Grand Junction, CO
Posts: 131
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I took mine in when it was doing this, and they replaced a vacuum pump. That fixed the problem. Luckily it was covered by warranty.

Joe

2006 F250 Lariat FX4







4" Turbo back straight piped exhaust
MeltonUnlimited is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome