04 350 Electrical problem - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-08-2010, 04:55 AM
Member
 

Join Date: Mar 2010
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
04 350 Electrical problem

Hi all, I have a 2004 F350 4x4 Crew cab, with the 6.0 in it. To start off all my problems, a couple days ago, the ABS light came on. OK, no problems with normal braking, and everything else is working fine, so I said heck with it for now, I'll have it checked out later. Well...the next day, the speedometer quit working. Then, later that evening, I noticed when I got home and turned the truck off and removed the key, instead of staying on the normal few minutes or until you open the door, the radio turned off instantly, but then it came back on about 5 seconds later, and wouldnt turn off EVEN WHEN THE DOOR WAS OPENED. I sat there a couple minutes with the door open, and I finally heard the click and the radio shut off. Later on, when it got dark, I tried it all again, cranked up and shut back down, same problem, radio off, then back on, and stayed on when I opened the door. Since it was dark this time, I also noticed that when I shut the switch off and the radio went off and powered back up, that all the guage warning lights, such as the abs, brake, and any other written word warning lights on the cluster were glowing very dimly. This time I closed it up and went inside for about 20 or 30 minutes then went back out to check it, and the radio was still on! I unplugged the batteries, to hopefully reset something, and the terminals were perfectly clean by the way, because I had new batteries installed about 4 months ago, and then reconnected them about an hour and a half later, but the problem didnt go away. Could all these problems, the ABS light, speedo, and radio/warning light problems be related to the same thing?? Ive heard that possibly the radio timer relay was powered by the gauge cluster, so could the whole thing be the cluster going bad?? Can it be reprogrammed?? ANY IDEAS?? This is my only mode of transportation, I need it to stay in one piece!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-08-2010, 07:28 AM
Compression Ignition Addict
 

Join Date: Jul 2008
Location: harlingen tx
Posts: 1,138
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
idk why it would cause the radio to do that but the abs light and speedo not working generally points to the speed sensor so i would replace that and see if it works
Reply With Quote Quick reply to this message
  #3  
Old 03-19-2010, 02:01 PM
Powerstroke.org Rookie
 

Join Date: Jun 2009
Location: Edgewood, NM
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ck yer charging system. If you dont have the right voltage then things will start wierding out. Just my .02c
Reply With Quote Quick reply to this message
  #4  
Old 03-19-2010, 05:58 PM
Member
 

Join Date: Mar 2010
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yeah, but mine turned out to be one little ground wire lost its ground....the one to the ABS module. When I found and regrounded it, ALL the problems went away.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:49 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors