2005 Ford F350 Power Windows and Radio died - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 12-22-2009, 06:02 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2009
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2005 Ford F350 Power Windows and Radio died

Hey guys

I am super stuck on this one.

Sunday I installed my navigation system antenna. I ran it through the 3rd brake light, and then straight down my headlinner in a Crewcab. Put everything back together and SHAZAAM My power windows, radio, and map lights don't work any more. I believe they all run on some kind of delay circuit???

So far I have:
- Tested and checked every fuse and relay in the truck.
- Checked every wire harness (all good)
- Checked to see if I shorted out the antenna (Disconnected it and no difference)
- Checked to see if I may have shorted out the dome lights. Doesn't appear to have, the dome lights work, but the map lights don't.
- I didn't touch the instrument cluster??/

Can anyone help with some fresh ideas?????/
This is driving me nuts, no windows or stereo for 3 days now.
Any help would be appreciated.
95Harley is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 12-27-2009, 07:41 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2009
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well

I ended up bypassing the battery save circuit bu jumping from ans ignition controlled + circuit to the relay. It all works again
95Harley is offline  
post #3 of 3 Old 09-01-2014, 09:26 AM
Powerstroke.org Rookie
 
travb69n's Avatar
 
Join Date: Aug 2014
Location: Southeast houston
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
i may be a few years late on this one, but could you elaborate bypassing the battery save circuit. im having this issue right now after i put in an oversized fuse (#41 i believe). i now have the recommended 10 amp fuse in and no power to it
travb69n is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome