A/c Problems - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-11-2005, 03:36 AM
Powerstroke.org Rookie
 

Join Date: Sep 2005
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question A/c Problems

Has Anyone Had Any Isssue With Your Heater Controls. I Think They Call It The Automatic Climate Controls. I Have Been Having My Display Go Blank And Nothing Works. The Dealership Has Checked It Out 2 Times And Have A Module Ordered. Mine Is A 2005 F-350 Crewcab Drw Xlt Lariat. Anybody Else Had Any Issues? Eventually It Will Start Back To Working, Usually After Starting Truck Two Or Three Times And Trying To Turn On And Off Several Times. THIS TRUCK IS IN THE KENTUCKY AREA . DON'T KNOIW IF IT MAKES A DIFFERNCE OR NOT. THANKS

Last edited by j4047; 09-11-2005 at 03:38 AM. Reason: STATE OF DELIVERY FOR VEHICLE
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-11-2005, 06:07 AM
Gun Nut




 

Join Date: Jul 2005
Location: Katy, Texas
Posts: 13,845
Thanks: 7
Thanked 34 Times in 24 Posts
Feedback Score: 0 reviews
Send a message via AIM to Rodslinger
Welcome j4047!
I don't have that option on my '05 so I can't help but I'm sure someone will chime in soon.
Reply With Quote Quick reply to this message
  #3  
Old 09-11-2005, 11:56 AM
Compression Ignition Addict
 

Join Date: Aug 2005
Location: Heppner, Or. Population 1000
Posts: 229
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Send a message via MSN to turbotime Send a message via Skype™ to turbotime
ac probs

well, i have an older truck than yours, and this probobly is not the problem, but mine was doing something similar and it ended up being some wires that got kicked under the dash. You might want to double check all the connections in that area.

Just a thought, it can't hurt to check at least!
Reply With Quote Quick reply to this message
  #4  
Old 11-30-2006, 10:07 AM
Ken Ken is offline
Powerstroke.org Rookie
 

Join Date: Nov 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
heater problems

I too have problems with the heater being stuck in "defrost" mode. It stays there with the A/C on as well. I can hear the switch up front when selecting the various dials for floor/defrost/both etc., but does not change. Help?
Reply With Quote Quick reply to this message
  #5  
Old 04-19-2007, 06:20 PM
Powerstroke.org Rookie
 

Join Date: Apr 2007
Location: Oyens Iowa Po Box 596
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
AC & Heat problems

also have had problems with heater twice now it has quit working and the next day it just starts working again .any ideas on what might be wrong ???:
Reply With Quote Quick reply to this message
  #6  
Old 04-19-2007, 07:00 PM
Jon
Guest
 
Posts: n/a
I have

replaced many of those units.
Reply With Quote Quick reply to this message
  #7  
Old 04-20-2007, 01:02 PM
LTJDS
 

Join Date: Jul 2006
Location: Miami
Posts: 553
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
A/C problems

06" SD F350
Defrost Fan stays on high when A/c turned off. and when the key is full forward ready for start.??????????
When eng running a/c control fan speed takes over and adjusts as set high to low. Called the Stealer..........they said that it was a "bower control module" ? called the stealer for a parts price and they could not identify the correct part out of 2. one is $70 bucks the other $293...
I'm confident I can pull the dash to replace it. I just don't want to get the wrong part. No return on electronics
Any fimiliarities or suggestions
Thanks yall
Reply With Quote Quick reply to this message
  #8  
Old 05-15-2007, 04:58 PM
Compression Ignition Addict
 

Join Date: Nov 2006
Location: SoCal
Posts: 680
Thanks: 2
Thanked 2 Times in 1 Post
Feedback Score: 0 reviews
Quote:
Originally Posted by j4047 View Post
Has Anyone Had Any Isssue With Your Heater Controls. I Think They Call It The Automatic Climate Controls. I Have Been Having My Display Go Blank And Nothing Works. The Dealership Has Checked It Out 2 Times And Have A Module Ordered. Mine Is A 2005 F-350 Crewcab Drw Xlt Lariat. Anybody Else Had Any Issues? Eventually It Will Start Back To Working, Usually After Starting Truck Two Or Three Times And Trying To Turn On And Off Several Times. THIS TRUCK IS IN THE KENTUCKY AREA . DON'T KNOIW IF IT MAKES A DIFFERNCE OR NOT. THANKS
I have an 05 F-250 CC Lariat. I have had the exact same problem that you tell of. It has only happened a couple of times. I have not done anything about it, but you are not the only one.
Reply With Quote Quick reply to this message
  #9  
Old 05-15-2007, 05:11 PM
Compression Ignition Addict
 

Join Date: May 2007
Location: America
Posts: 6,782
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
I've had the same problem twice on my xlt and it turned out to be a vacuum hose. I don't know if the lariats are the same but thats what my problem was.
Reply With Quote Quick reply to this message
  #10  
Old 06-29-2007, 05:33 PM
Member
 

Join Date: Jul 2006
Location: Elizabethtown, KY
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mine quit working today and has not started back. I checked the fuses but they were good. Did you all find out what was causing the problem? Hate to have to buy that unit probably lots of $$$. This is on my '05

Thanks,
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:00 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors