Transmission acting up - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-14-2013, 06:07 AM
Powerstroke.org Rookie
 

Join Date: Jan 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Transmission acting up

I've done a little searching and found a few with similar problems, but didn't see a fix. I have an 07 F350. No performance mods besides a sct tuner with mild tunes from Erik @ innovative.

Transmission started acting funny last week. It would take a second or two to actually engage when put into drive, but it only happened once or twice all week. Now itís getting worse. The slow to engage only seems to happen after it has been running a while, but it will take a while to downshift when accelerating. Doesnít do it every time, but it is happening more frequently. I know itís time for me to change my filter and fluid, but this problem is scaring me a little. Not sure which direction to go. I have already ordered an 08 tranny pan and filter, but wonít be able to do that for another week. Any advice would be appreciated
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-07-2013, 09:42 PM
Powerstroke.org Fanatic
 

Join Date: Oct 2011
Location: TULSA,OK
Posts: 99
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by jakeF16 View Post
I've done a little searching and found a few with similar problems, but didn't see a fix. I have an 07 F350. No performance mods besides a sct tuner with mild tunes from Erik @ innovative.

Transmission started acting funny last week. It would take a second or two to actually engage when put into drive, but it only happened once or twice all week. Now itís getting worse. The slow to engage only seems to happen after it has been running a while, but it will take a while to downshift when accelerating. Doesnít do it every time, but it is happening more frequently. I know itís time for me to change my filter and fluid, but this problem is scaring me a little. Not sure which direction to go. I have already ordered an 08 tranny pan and filter, but wonít be able to do that for another week. Any advice would be appreciated


Mine is doing the same thing. Did you ever figure out your problem?
Reply With Quote Quick reply to this message
  #3  
Old 07-08-2013, 02:06 AM
Powerstroke.org Rookie
 

Join Date: Jan 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i haven't had time to dive farther into it yet. still a delay shifting into gear from park and sometimes from reverse to drive, but the filter and fluid change seemed to help. i did not do a flush though. just drained fluid and changed both filters.
Reply With Quote Quick reply to this message
  #4  
Old 02-23-2014, 01:45 AM
Compression Ignition Addict
 

Join Date: Mar 2009
Location: No, Ill
Posts: 746
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Did u find out what the problem was?

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:49 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors