Flashing TOW/HAUL light with CODES - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-02-2012, 08:29 AM
Member
 

Join Date: Jun 2012
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Unhappy Flashing TOW/HAUL light with CODES

Well...as murphy's law kick in on my Sunday of planned sitting around eating and sucking down some cold ones while watching football...

my 2006 F250 decides to start something new.

The Tow/Haul light came on and started flashing with the CEL light on continuously with an associated shutter in the transmission. I am able to read the codes with my CTS;

P0700- Transmission Control System Malfunction.
P0758- SSB control Circuit Electrical Failure.
P0976- SSB control Circuit Low.

What would the best place to start troubleshooting? or what sensors/controls would be best to replace?

Any advice is greatly appriciated,
Damon

PS- I do not have a good working knowledge of this transmission.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-02-2012, 08:41 AM
Member
 

Join Date: Jun 2012
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I just found on another forum that the P0758 and P0976 codes point to the;
2-3 shift solenoid.

Is this an easy replacement? Is it located internally or Externally?
Reply With Quote Quick reply to this message
  #3  
Old 12-02-2012, 08:46 AM
Compression Ignition Addict
 

Join Date: Feb 2008
Posts: 7,622
Thanks: 57
Thanked 127 Times in 121 Posts
Feedback Score: 0 reviews
internal very easy
Reply With Quote Quick reply to this message
  #4  
Old 12-02-2012, 08:48 AM
Compression Ignition Addict
 

Join Date: Feb 2008
Posts: 7,622
Thanks: 57
Thanked 127 Times in 121 Posts
Feedback Score: 0 reviews
the pan gasket is reusable and it's a good time to just dump the fluid and add 7ish more quarts

you may have a wire issue however at least by my untrained diagnostics
Attached Thumbnails
Flashing TOW/HAUL light with CODES-solenoid-body-pic.jpg  
Reply With Quote Quick reply to this message
  #5  
Old 12-02-2012, 08:58 AM
Member
 

Join Date: Jun 2012
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by ZMANN View Post
the pan gasket is reusable and it's a good time to just dump the fluid and add 7ish more quarts

you may have a wire issue however at least by my untrained diagnostics
Thanks ZMANN,

I notice in your Pic you submitted, there are several Solenoids. Which one is the 2-3 shift Solenoid? Or should I replace all of them while I'm in there? Are they all different? or the same part number....?

Thanks
Reply With Quote Quick reply to this message
  #6  
Old 12-03-2012, 02:15 AM
Member
 

Join Date: Jun 2012
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by new2fossil View Post
Well...as murphy's law kick in on my Sunday of planned sitting around eating and sucking down some cold ones while watching football...

my 2006 F250 decides to start something new.

The Tow/Haul light came on and started flashing with the CEL light on continuously with an associated shutter in the transmission. I am able to read the codes with my CTS;

P0700- Transmission Control System Malfunction.
P0758- SSB control Circuit Electrical Failure.
P0976- SSB control Circuit Low.

What would the best place to start troubleshooting? or what sensors/controls would be best to replace?

Any advice is greatly appriciated,
Damon

PS- I do not have a good working knowledge of this transmission.

Well, I really need some more knowledge about this. I there anyone out there with a good working knowledge of this issue. Otherwise, I will leave it up to ford.

Thanks,
Damon
Reply With Quote Quick reply to this message
  #7  
Old 12-03-2012, 01:33 PM
Member
 

Join Date: Jun 2012
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
FOUND THE PROBLEM. Main transmission wire harness wasn't routed correctly (from previous work) and rubbing on the drive shaft...repaired and rerouted wires...cleared codes and BAM! no more problem.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
p0700, p0758, p0976, tow/haul

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:18 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors