I think I blew my trans - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-02-2012, 11:32 AM
Powerstroke.org Fanatic
 

Join Date: Aug 2008
Posts: 108
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I think I blew my trans

My trans quit me yesterday and I don't know if it's completely destroyed or if I can fix it.
Truck was bought Dec 26th 2006 and has 50,140 miles.


When I put it in gear from park (forward or reverse) it take quite some time to go into gear and when it does, it slams into gear.
Then it slips when changing gears until it goes from 4th to fifth.
Then it drives perfect...until it tries to change gears again.
Then the tow/haul light flashes and it stays in second gear.
I pull over and shut it off and restart the engine and do it all over again.
After driving a ways and have to stop the T/Q wont unlock and tries to stall the engine.

I pull the codes with Auto Enginuity and get:


P0756 Shift solenoid B performance or stuck off
P2701 Transmission Friction Element B apply time/range/performance
P2703 Transmission Friction Element D apply time/range/performance



Any help?

Last edited by genesis; 11-02-2012 at 11:40 AM. Reason: I cant spell
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-02-2012, 02:58 PM
Premium Member
 

Join Date: Mar 2012
Posts: 1,227
Thanks: 8
Thanked 10 Times in 10 Posts
Feedback Score: 0 reviews
mabey your solenoid is sticking ?
Reply With Quote Quick reply to this message
  #3  
Old 11-02-2012, 06:22 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2008
Posts: 108
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by turbotibbo View Post
mabey your solenoid is sticking ?
Does that normally cause the T/C to stay locked up?
Reply With Quote Quick reply to this message
  #4  
Old 11-02-2012, 08:27 PM
Compression Ignition Addict
 

Join Date: Sep 2012
Location: The place where the 2nd amendment is considered illegal.
Posts: 252
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Your transmission is running with the original oil in it? 50xxx miles IS A LOT if you haven't change it. How about the transmission filter/s .You haven't mentioned if you have changed the oil and filter recently. We need more information and lets start with the basic. Keep us informed.
Reply With Quote Quick reply to this message
  #5  
Old 11-03-2012, 07:38 AM
Powerstroke.org Fanatic
 

Join Date: Aug 2008
Posts: 108
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
The fluid and filter have not been changed.
I was under the impression it was to be changed at 50K.
Would that indicate that I have ruined my trans?
I am going to drop the pan today and see what it looks like.
Reply With Quote Quick reply to this message
  #6  
Old 11-03-2012, 09:41 AM
Premium Member
 

Join Date: Mar 2012
Posts: 1,227
Thanks: 8
Thanked 10 Times in 10 Posts
Feedback Score: 0 reviews
its hard to say , i amj no trans expert but mabey try unpluging the battires and reseting the keep alive memory and then performe the relearn . do that after the dropping of the paqn and both filter and oil change ........after that if it still wont work it must be a solenoid gone bad ? good luck
Reply With Quote Quick reply to this message
  #7  
Old 11-04-2012, 10:18 AM
Premium Member
 

Join Date: Jan 2012
Location: Fallon, Nv
Posts: 2,403
Thanks: 53
Thanked 10 Times in 9 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by genesis View Post
My trans quit me yesterday and I don't know if it's completely destroyed or if I can fix it.
Truck was bought Dec 26th 2006 and has 50,140 miles.


When I put it in gear from park (forward or reverse) it take quite some time to go into gear and when it does, it slams into gear.
Then it slips when changing gears until it goes from 4th to fifth.
Then it drives perfect...until it tries to change gears again.
Then the tow/haul light flashes and it stays in second gear.
I pull over and shut it off and restart the engine and do it all over again.
After driving a ways and have to stop the T/Q wont unlock and tries to stall the engine.

I pull the codes with Auto Enginuity and get:


P0756 Shift solenoid B performance or stuck off
P2701 Transmission Friction Element B apply time/range/performance
P2703 Transmission Friction Element D apply time/range/performance



Any help?
Drop pan, change solenoid B with CORRECT pn (they all look alike but act mucho differento), change pan filter, change filter on right frame rail near radiator, fill with SP ONLY (my local OReilly's carrys Motorcraft SP for about $5/qt), clear codes, re-evaluate.

When my trans took a dump, it had the same Park/Nuetral to D lag. But it also had other shifting issues than what you have described.
Reply With Quote Quick reply to this message
  #8  
Old 11-04-2012, 11:36 AM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Dover
Posts: 1,619
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sounds like a solenoid problem to me. I dont know your trans at all but thought ford built those as a solenoid "pack".

Don't drive the truck anymore!! If it is partially engaging the clutches and is slipping, you will cause more damage.
Reply With Quote Quick reply to this message
  #9  
Old 11-04-2012, 12:09 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2008
Posts: 108
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for the replies!
Which one is Solenoid B?
Would that one cause the T/C to stay locked up when I slow to a stop?
Best place to buy one?
Reply With Quote Quick reply to this message
  #10  
Old 11-04-2012, 12:15 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Dover
Posts: 1,619
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Things can get kinda weird if a solenoid shorts out.

My best advice is go to your ford dealer and hopefully they are helpful. I am friends with the dealership here so I would go there and look at their diagrams and such. Also, that is likely the only place you can buy the solenoid.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:41 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors