2006 F350 Transmission Codes/Tow Haul Flashing - Ford Powerstroke Diesel Forum
LinkBack Thread Tools Display Modes
post #1 of 2 Old 09-26-2012, 04:31 AM Thread Starter
Powerstroke.org Rookie
Join Date: May 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
2006 F350 Transmission Codes/Tow Haul Flashing

Back in March when towing a trailer (approx weight: 8K) I was using Tow/Haul and it started flashing within about 5 minutes after engaging. I had the codes checked and the following came up:

P0700 & P0751

I continued to drive the truck not noticing any shifting issues. I have not pulled the trailer since. I recently had the FICM rebuilt and installed an Edge CTS. I noticed that all codes were cleared since the battery was removed for a few days. But just yesterday I was coasting down a small hill when the Tow/Haul seemed to engage itself and both of the codes above popped up again. I also noticed a few minor misshifts/jerky shifts for the next mile or so.

Drove the truck roughly 50 miles since with no apparent shifting issues. Was planning on draining the transmission fluid and changing this weekend. I have read a few forums posts on these codes (particularly P0751) and have noticed many mention chaffed wires/bad electrical connections. What in should I be looking for in particular? And if a selenoid needs replacing... what part # should I be looking for? Are they difficult to replace? I was planning on dropping the pan and looking for debris as well... and changing the internal/external filters while I was under there.

Any help would be greatly appreciated!
seanjaeger is offline  
post #2 of 2 Old 10-02-2012, 05:20 AM Thread Starter
Powerstroke.org Rookie
Join Date: May 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
In aother forum I was sent a picture of the solenoids... I replaced the one that was labeled SSPC-A... after a little research I found that it was the SHIFT SOLENOID PRESSURE CONTROL A... which makes sense based on the DTC I was getting.

Unfortunately after replacing and putting everything back together I am still getting the flashing tow/haul light and same DTC when I turn tow/haul on.

P0700 - comes on shortly after clearing codes
P0751 - comes on shortly after engaing tow/haul

In the picture there was another solenoid labeled PC-A. Which I assume is just PRESSURE CONTROL A? Should I attempt to change this one out?

I also checked all the wiring and it looked good.... didn't see any chaffing. No sediment or metal pieces in the pan... fluid actually looked very clean still ... solid red no browning.
seanjaeger is offline  

6.0l , codes , transmission

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome