ONLY THIRD GEAR!!! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-25-2012, 05:04 PM
Member
 

Join Date: Feb 2012
Posts: 63
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ONLY THIRD GEAR!!!

Hey guys I really need some help. A few months ago the tow haul light started flashing on my truck and threw the code p0757 shift solenoid B stuck on. Well I could just restart the truck and it would go away. As time went by it started happening all the time and I couldnt get it to stop. I then realized I had no first gear and it shifted weird, especially down shifting in tow haul mode. I replaced the solenoid and it didnt do anything. As more time went by, still no first, but under moderate to full throttle it wouldnt shift into third i believe. It would just repededly try to bang into gear until you backed off. Well now all I have is third gear and reverse. Also sometimes it takes a few seconds to shift into reverse of drive. Im not too sure if this is normal or also part of my problem. Oh and one more thing, not too long ago when i would start it up in the morning and put it in reverse it would just bog down and act like it was slipping under heavy load and then just release and be normal. Well anyways if anyone has some input for me I would really appreciate it. Thank you all in advance.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-06-2012, 06:48 AM
Another 6Slow
 

Join Date: Jul 2009
Location: yorkville, IL
Posts: 431
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I would be willing to bet that your overdrive clutches are toast!
Reply With Quote Quick reply to this message
  #3  
Old 07-09-2012, 07:27 AM
Compression Ignition Addict
 

Join Date: Mar 2007
Posts: 4,556
Thanks: 2
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
any update on this? I see your sig says 'suncoast tranny parts'.
Reply With Quote Quick reply to this message
  #4  
Old 09-08-2012, 06:03 AM
Member
 

Join Date: Feb 2012
Posts: 63
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Just thought I'd give an update, although its been awhile. Tranny was internally busted and had to be rebuilt again. Some kind of drum thats in these trannys was all messed up.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:37 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors