electical issue? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-04-2012, 05:36 PM
Powerstroke.org Rookie
 

Join Date: Jan 2012
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
electical issue?

so i have a 2006 F250 Auto. problem is it won't shift pass 1st gear when in drive. but when i manually shift it from 1st to 2nd and then 2nd to 3rd it'll shift. then i'll shift from 3rd to drive and it'll kick back down to 1st instead of going to 4th. never seen this problem before. also no codes present for both PCM and TCM. fluid is clean and doesn't smell burnt. any type of direction well be great help. thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-05-2012, 06:54 AM
Compression Ignition Addict
 

Join Date: Jul 2011
Location: Houston, TX
Posts: 264
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
If it shifts manually, then the transmission itself seems fine physically. Sounds like the TCM itself is just not telling it to shift for whatever reason.

Check all your sensors and connections to the TCM, I wonder if the TCM is just not seeing the speed/rpm's properly, and therefore doesn't think you're moving yet? I dunno. Is your speedometer/tach working properly?
Reply With Quote Quick reply to this message
  #3  
Old 04-05-2012, 09:36 AM
Powerstroke.org Rookie
 

Join Date: Jan 2012
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
tech is working. i didn't notice if the speedo was working tho. was to busy looking at the scanner. but i'll check that in a bit and also my wiring. wiring around the tranny seem to be fine tho
Reply With Quote Quick reply to this message
  #4  
Old 04-05-2012, 05:22 PM
Powerstroke.org Rookie
 

Join Date: Jan 2012
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
finally had time to go on another test drive. tech works but speedo does not. was trying to see if the speed sensors are working but i have no comm. with the ABS module. FML!
Reply With Quote Quick reply to this message
  #5  
Old 04-06-2012, 09:55 AM
Powerstroke.org Rookie
 

Join Date: Jan 2012
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
update: ok so i have no comm. to the ABS module which gives me reason to believe that's what is causing my tranny issue. i have power going to the module and my grounds are good. ohmed the CAN wires from the module to the DLC and i'm getting .3 on both wires. would this mean my ABS module is bad?
Reply With Quote Quick reply to this message
  #6  
Old 04-12-2012, 05:04 PM
Powerstroke.org Rookie
 

Join Date: Jan 2012
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
update: replaced the ASB module and finally got comm. and my speedo is now working. all speed sensors work but truck is still not shifting pass 1st.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:06 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors