Bad TC? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-20-2011, 07:54 AM
Compression Ignition Addict
 

Join Date: Feb 2011
Location: Wilmington
Posts: 413
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Bad TC?

when I hit overdive around 60-65mph, it almost feels as though it slipps or as if the TC is lcking and unlocking really fast. I've also been told it could be an injector issue?? Any Thought? Thanks!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-20-2011, 08:04 AM
Compression Ignition Addict
 

Join Date: Feb 2011
Location: Wilmington
Posts: 413
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have unplugged the batteries hoping to reset the computer and it can relearn? If not off to the dealer for a diag...
Reply With Quote Quick reply to this message
  #3  
Old 08-21-2011, 09:05 AM
Powerstroke.org Rookie
 

Join Date: Apr 2011
Location: North Ogden
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have the same problem. Tell me more about yours. I have an Edge Insight and mine seems to only do it when Torque Converter locks up (TCC ratio = 1.00) I aslo noticed that it doesn't do it when its cold. Not sure if its when Engine is cold or tranny is cold, but when I first start it up it wont stutter/miss/buck (or whatever its doing). Engine Idles perfectly, and when I step on it it runs like a bat out of hell. It does it on factory tune and my aftermarket tunes. It's more noticeable the faster I go. At 50mph barely noticeable. at 70 Mph very noticeable. I've been struggling with this ever since I rebuilt the engine.
Reply With Quote Quick reply to this message
  #4  
Old 08-21-2011, 09:59 AM
Compression Ignition Addict
 

Join Date: Feb 2011
Location: Wilmington
Posts: 413
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mine is more noticeable when its hot, I still get a "break-up" when accellerating, but the shudder is more when it hits overdrive after it has warmed up, I don't get a TCC reading on my insight
Reply With Quote Quick reply to this message
  #5  
Old 08-21-2011, 06:19 PM
Powerstroke.org Rookie
 

Join Date: Apr 2011
Location: North Ogden
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
On a side note I wanted to say thanks to all the people who post here. You've really helped me with my Excursion. I have been able to pull the motor and fix most of the nasties thanks to all the post on this forum.
Reply With Quote Quick reply to this message
  #6  
Old 09-01-2011, 02:49 PM
Powerstroke.org Rookie
 

Join Date: Apr 2011
Location: North Ogden
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I took the Excursion to the dealer today, they wont be done till tomorrow, but I'm thinking my problem is an injector. Hopefully they will be able to tell me which one.
Reply With Quote Quick reply to this message
  #7  
Old 09-01-2011, 03:31 PM
Compression Ignition Addict
 

Join Date: Mar 2011
Location: wichita ks
Posts: 971
Thanks: 0
Thanked 4 Times in 3 Posts
Feedback Score: 0 reviews
Not trying to discount your problem, however sometimes turbo surging can cause a similar experience. I have even had some people tell me they had a transmission / engine problem and they were feeling the AC clutch turn on and off and change the loading on the engine. This could very well be an injector or FICM problem. Let us know what the dealer says.
Reply With Quote Quick reply to this message
  #8  
Old 09-01-2011, 05:27 PM
Powerstroke Techie


 

Join Date: Jan 2011
Location: UPPER SALFORD PA
Posts: 2,023
Thanks: 80
Thanked 60 Times in 32 Posts
Feedback Score: 13 reviews
does it feel like rumble strips when it happens if so the clutch in the converter is bad.
Reply With Quote Quick reply to this message
  #9  
Old 09-01-2011, 05:52 PM
Compression Ignition Addict
 

Join Date: Feb 2011
Location: Wilmington
Posts: 413
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
it does not, it feels like i am driving through a puddle at 60 mph....

and usually only happens on a slight hill or from initial accelleration (misfire)???
Reply With Quote Quick reply to this message
  #10  
Old 09-01-2011, 05:53 PM
Compression Ignition Addict
 

Join Date: Feb 2011
Location: Wilmington
Posts: 413
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
several small puddles that is, unless you mean a weak weak rumble strip?

also, initial accel at WOT, the tach climbs climbs drops slighltly climbs stalls drops steady

edit #2 lol- I am also getting wierd quick howling noises, intercooler, boost tubes???

Last edited by DEESLVRGN; 09-01-2011 at 05:56 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
slipping, torque converter

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:23 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors