4X4 Low - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 01-22-2011, 02:08 PM Thread Starter
Member
 
Join Date: Dec 2010
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
4X4 Low

put the truck in 4x4 low to plow some snow the othere day was alright in foward but when i came to a compleat stop and put it in reverse wated a minet and it wouldent go when it did it went with a big clunk after that i fineshed off in hight any idea what might be causing it. all the U joints are good.
Eddiy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome