Sticking PC-A or something else? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 07-26-2010, 09:36 AM Thread Starter
TwistedSS's Avatar
Join Date: Nov 2009
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sticking PC-A or something else?

Towed a friends car down to the beach last week with no issues at all. Unhooked the trailer and drove around a bit. I backed the truck into a parking space and went into the hotel for about an hour. Went to go get dinner and put the truck in drive and it wouldnt move. I let it idle for about 30 minutes the next day and put it in gear and it moved...shifted normally and all seemed fine. Now it is slow to engage any gear from park after the truck is cold. Could this be a sticking solenoid or possibly something else? Tow haul mode light will flash after about ten minutes of driving with the tow haul mode on but it won't go into limp mode or anything. My truck is an 03 Excursion 6.0 with a freshly rebuilt trans (two months ago using Alto Reds and new seals, etc).

Thanks in advance

-2003 Excursion Limited, 6.0, 4x4, Lifted on 35" Toyo M/T's, Mickey Thompson, Magnaflow, Tuned by Quick Tricks.
-1998 Mustang GT. Typical slow 2v.
TwistedSS is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome