tranny running cooler - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 04-16-2010, 07:58 AM Thread Starter
Powerstroke.org Fanatic
 
Join Date: Jul 2007
Posts: 130
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
tranny running cooler

I judt did the tranny fluid change and the tp filter in the front. I have noticed the tranny runs much cooler on myh dash gauge and it takes alot longer to to come all the way up to temp. Before it would be up to temp and higher then what is normal now in just a few minutes not it may take 10 min. Any one else experiance this? I assume the cooler temps are good.

2011 f250 6.7
Straight piped
SCT x4 custum tuned
Deleated
gtnit is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome