slip in 1st and 2nd... need advice - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-12-2009, 10:10 AM
Compression Ignition Addict
 

Join Date: Mar 2009
Posts: 451
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
slip in 1st and 2nd... need advice

truck recently started slipping in 1st and 2nd. the truck was fine until i towed a light load and thats when i felt it slip and has been since. under normal driving its fine but in hard acceleration it revs up and shifts late. and occasionally in 3rd the truck will pull good then around 3 grand it feels as is if it hits nitrous, feels like it grabs hard. fluid is full and clean.

what do you guys think?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-13-2009, 03:14 PM
Compression Ignition Addict
 

Join Date: Mar 2009
Posts: 451
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
bump... please help me out.
Reply With Quote Quick reply to this message
  #3  
Old 07-13-2009, 05:04 PM
Compression Ignition Addict
 

Join Date: Jul 2009
Location: Houston, Texas
Posts: 656
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Id take it to a tranny shop and have them pull some codes for you to see what could be the prob.

But thats just me.
Reply With Quote Quick reply to this message
  #4  
Old 07-14-2009, 06:59 PM
Compression Ignition Addict
 

Join Date: Mar 2009
Posts: 451
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
any other advice
Reply With Quote Quick reply to this message
  #5  
Old 07-14-2009, 07:03 PM
Compression Ignition Addict
 

Join Date: May 2007
Location: America
Posts: 6,783
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Go to dealer and ask them to scan the codes for free.
Reply With Quote Quick reply to this message
  #6  
Old 08-25-2009, 07:22 AM
Member
 

Join Date: Nov 2007
Posts: 54
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i had the same problem. If you are still under the warranty then go back to FORD. I was out of warranty i have 108K and just bought JASPER Tranny! Just installed it on 08/19/09 and it's so nice.....and smooth. 3years or 100,000 miles warranty.

Good luck

Robert
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:09 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors