speedo not working and loss of power???? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-18-2009, 09:31 AM
Compression Ignition Addict
 

Join Date: Mar 2008
Location: Stafford, VA
Posts: 175
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
speedo not working and loss of power????

Three times now I have started the truck and took off and it feels like the truck doesnt have enough power to get out of its own way. I look down and the speedo is sittin on 0 mph not working. RPM's go up, boost goes up, truck just doesnt have any problems. No check engine light or nothing. Go down the road for a few miles and bam! The speedo starts working and the truck is back to life with all the power in the world. Just wondering if anyone else has had this problem and if so any ideas to what is causing it?? Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-18-2009, 12:04 PM
Compression Ignition Addict
 

Join Date: Aug 2007
Location: tucson,az.
Posts: 172
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have had this happen to me. took it to the dealer and they put a new cluster in it. I was told that there is a TSB out about this. hope this helps.
Reply With Quote Quick reply to this message
  #3  
Old 05-18-2009, 03:32 PM
Compression Ignition Addict
 

Join Date: Mar 2008
Location: Stafford, VA
Posts: 175
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
so i take it this would only be covered under the bumper to bumper warranty not the motor warranty? also did it fix the problem for you?
Reply With Quote Quick reply to this message
  #4  
Old 05-20-2009, 05:48 AM
Compression Ignition Addict
 

Join Date: Mar 2008
Location: Stafford, VA
Posts: 175
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
just talked to the dealer and they said it sounded like the egr was causing the problem. just wondering if that makes any sense or are they just makin stuff up?
Reply With Quote Quick reply to this message
  #5  
Old 05-22-2009, 03:16 PM
Compression Ignition Addict
 

Join Date: Mar 2008
Location: Stafford, VA
Posts: 175
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
took truck to dealer today. they finally called and said they didnt know what was up with the speedo and no power, but i told them that it felt like it was missing and they said that i had at least 1 injector going bad if not more. they would know more on tuesday when they get back from holiday weekend! good thing i took it in only 7K miles left on the motor warranty.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:46 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors