Truck has a mind of its own? help - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 10 Old 04-26-2009, 03:13 PM Thread Starter
Powerstroke.org Fanatic
 
DustyDiesel83's Avatar
 
Join Date: Nov 2007
Location: Dunkirk, In
Posts: 99
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Truck has a mind of its own? help

So it started a couple of weeks ago. I was driving down the road and all of a sudden the truck decides to just give it self a little bit of throttle. This got my attention real quick. The truck belches black smoke every time it does this. The cel came on every once in a while but all this week it has been on, just haven't had time to fix it. The idle is also jacked up, its just fine at start up but after a minute it jumps up to 1200 rpms for a couple of seconds and settles down to the 800's which is higher than normal.

My truck had an edge box on it till today. I thought maybe it was the problem, but it wasn't. I took the box off and started my truck back up and it idled fine so i decided to take a test drive. This was a bad move. The truck ran fine for about a mile. As i was coming to a stop sign the truck just shut off. Started back up but as i gave it some throttle in neutral it was throwing a little bit off black smoke.

Problem number 2 is as i left the stop sign i went about 2 more miles and the truck started shifting funny. it didn't want to shift, hanging in between gears and the tow haul light started flashing. never had any problems with my truck ever till now. This kind of has me all bummed out need all the help i can get thanks.
DustyDiesel83 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 04-26-2009, 03:37 PM
Mob boss

 
Jarrod B's Avatar
 
Join Date: Jul 2008
Location: Austin Texas
Posts: 26,951
Thanks: 25
Thanked 29 Times in 27 Posts
Mentioned: 2 Post(s)
Quoted: 148 Post(s)
Feedback Score: 1 reviews
ok get the codes pulled and post them here

2006 Ford F250 CCSB FX4 6.0

Sold
1997 F350 CCLB 2WD 7.3
1999 F350 CCLB 4WD 7.3
2003 F350 CCLB FX4 6.0



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



LSP Chapter Director

LSP Group Threads

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Jarrod B is offline  
post #3 of 10 Old 04-26-2009, 04:23 PM Thread Starter
Powerstroke.org Fanatic
 
DustyDiesel83's Avatar
 
Join Date: Nov 2007
Location: Dunkirk, In
Posts: 99
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Decided to try and drive it around to see if it would learn to shift with out the edge box. It does great for a minute then all of a sudden it doesn't want to shift into 3rd and locks out overdrive, then the tow haul light flashes. If i put the truck in tow haul mode when i first start it up the thing shifts fine and overdrive is there. going to get the codes pulled tomorrow if i can.
DustyDiesel83 is offline  
post #4 of 10 Old 04-26-2009, 04:25 PM
Premium Member

 
Goose350's Avatar
 
Join Date: Nov 2008
Posts: 13,271
Thanks: 0
Thanked 5 Times in 5 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 2 reviews
Can you not get the codes from the Edge? On mine you can but its just the Insight

The Mullet Mod
Stock 2005 F-350 4x4
*Afe Intake
*4" TB Exhaust
*Scangauge
*SCT
*
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
oil bypass
*
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
water pump
*Tuned FICM
Goose350 is offline  
post #5 of 10 Old 04-26-2009, 04:26 PM
Emergency Services

 
Join Date: Apr 2008
Location: Beeville, TX
Posts: 1,489
Thanks: 1
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
The "run away" problem is almost certainly a bad ICP sensor. It is probably causing the dieing at idle problem too. And furthermore, it might be causing your tranny to go into limp mode because of the engine not running right.

Get your codes pulled and let us know..

Eli Benson - EMT, Ambulance Mechanic
----------
'08 F350 Dually KR - Spartan'd
'07 F250 CC SB 4x4 XLT - SCT /w Innovative Tunes
4 '09 & '10 E350 6.0l ambulances
1 '08 Duramax 6.6 (LMM) van ambulance
elibenson is offline  
post #6 of 10 Old 04-26-2009, 04:27 PM
Mob boss

 
Jarrod B's Avatar
 
Join Date: Jul 2008
Location: Austin Texas
Posts: 26,951
Thanks: 25
Thanked 29 Times in 27 Posts
Mentioned: 2 Post(s)
Quoted: 148 Post(s)
Feedback Score: 1 reviews
it sounds like there is a serious issue. knowing the codes will help to steer ya in the right direction to get it repaired.

2006 Ford F250 CCSB FX4 6.0

Sold
1997 F350 CCLB 2WD 7.3
1999 F350 CCLB 4WD 7.3
2003 F350 CCLB FX4 6.0



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



LSP Chapter Director

LSP Group Threads

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Jarrod B is offline  
post #7 of 10 Old 04-26-2009, 04:32 PM
If it aint a CAT itsa DOG

 
dieseldan2005's Avatar
 
Join Date: Apr 2007
Location: North Branch, MN
Posts: 4,553
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I agree with Eli, my bro's 04 did the same thing. The ICP sensor went out and his truck would just take off going down the freeway or sitting at a light. It was kinda dangerous. he had that replaced and all his problems went away.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Diesel Dan
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

10,000 LAKES CHAPTER MEMBER


2003 F350 Crew cab long box, FX4, 6.0, torqshift, Lariat.
dieseldan2005 is offline  
post #8 of 10 Old 04-27-2009, 06:25 PM
Premium Member
 
WEWILLE's Avatar
 
Join Date: Feb 2007
Location: Wisconsin
Posts: 1,366
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Could be ICP, codes and sensor data would be great.

ASE Certified Master Automotive/light duty truck Technician
ASE light diesel specialist
Ford Certified Diesel Technician
Isuzu Certified Gas/Diesel Technician

2007 F-250 PSD FX4 crew cab shortbox king ranch
2005 F-250 PSD FX4 crew cab short Box burned up
2013 Fusion 1.6L Ecoboost
2011 Ford Edge
1999 Dodge 2500 Cummins
WEWILLE is offline  
post #9 of 10 Old 04-30-2009, 02:48 PM
Powerstroke.org Rookie
 
mechman28's Avatar
 
Join Date: Aug 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
mine does the same thing but no codes no data, levels out whem you pull the ICP connector
mechman28 is offline  
post #10 of 10 Old 05-02-2009, 09:53 AM
Powerstroke.org Rookie
 
wtkeyes1986's Avatar
 
Join Date: Mar 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Mine too, I have hears that from alot of people too. I just pop in nuetral and let it go. Good Luck
wtkeyes1986 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome