boost drops, and can't get rpm's or power - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 04-21-2009, 05:43 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2009
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
boost drops, and can't get rpm's or power

So every once in a while while I'm driving the power drops off the map on my 04 f 250. The boost will go to 0 and my rpm's go to 1000 or so i think. I've tried mashing on the gas and eventually it will pick back up and run normal but, I'm not sure what is going on. I've also tried to let it coast and not mash on the pedal but it just seems like for some reason the turbo shuts down for a second and then comes back up.

I installed a edge juice system recently and I think that may be when the problem started. I'm going to try and remove it and see if that helps but I thought you guys might be a good resource as well.

Thanks
shokaconbite is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 04-21-2009, 06:13 AM
wriott
Guest
 
Posts: n/a
Mentioned: Post(s)
Tagged: Thread(s)
Quoted: Post(s)
vanes in the turbo may need to be cleaned, some one who is more experienced in that area is sure to show up. welcome to the ORG
post #3 of 4 Old 05-01-2009, 07:56 PM
Powerstroke.org Rookie
 
fordfx4psd's Avatar
 
Join Date: Apr 2009
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have the same problem with my 04 and i have had it since i bought the truck it got worse when i chipped it and i talked to a few people i unplugged my egr valve and have not had the problem since
fordfx4psd is offline  
post #4 of 4 Old 05-01-2009, 08:03 PM
Powerstroke.org Fanatic
 
Csolomon's Avatar
 
Join Date: Oct 2008
Location: Red deer
Posts: 149
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i would point toward egr is full of carbon.. if you have the edge incab unit check to see if there are any codes... if you get a egr range/performance... good chance you need to clean/replace the egr valve.. super easy right next to oil filter

2011 F-350 CC LB Lariat
H&S minimax
Full EGR delete
Stock Straight back exhaust
S&B CAI
Csolomon is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome