Got a "miss" problem - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 04-12-2009, 05:07 PM Thread Starter Rookie
Join Date: Apr 2009
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question Got a "miss" problem

Got a 2003 Excursion 6.0 with Banks Power Pack Kit. When driving under normal to lower speeds/rpm's I get what feels like a "miss". It will typically happen on an incline at lower rpm's with light acceleration. Don't notice any smoke when it happens and seems to go away if I let up on the accelorator and then get back on it. I had a EGR and P132B codes. I replaced the EGR and now only have the P132B code. Is this a injector issue?

May have found the problem. The bottom of the intake hose slid off the air cleaner box. I put it back on and gave it a run. So far I have not been able to reproduce the problem and the P132B has not come back yet. We will see.

Last edited by Bass6139; 04-12-2009 at 06:45 PM. Reason: Problem resolved?
Bass6139 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome