battery charge light - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-02-2009, 02:21 PM
Powerstroke.org Rookie
 

Join Date: Aug 2007
Location: bakersfield
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
battery charge light

So, my battery charge light was blinking on every once in a while, then it started getting worse. I chaned out my altenator, and thought it was going to take care of the problem.. Then a new symptom came up. My radio, my gauges, and my power windows all stopped working. I was reading on the org trying to find a similar problem, but no luck. I finally figured it was the new altenator, maybe the voltage regulator so I changed it again, and sure enough it worked. I wanted to post this incase sombody else has a similar problem with similar symptoms.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-02-2009, 02:27 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,007
Thanks: 0
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
batteries? relays? fuses?
Reply With Quote Quick reply to this message
  #3  
Old 04-02-2009, 02:29 PM
Cynic
 

Join Date: Jun 2007
Location: Fort Worth, Texas
Posts: 11,194
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Nope. Alt was bad.
Reply With Quote Quick reply to this message
  #4  
Old 04-02-2009, 02:57 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,007
Thanks: 0
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
i would like to retract my previous statements and make a new one
"i not read right. i "

thank you
Reply With Quote Quick reply to this message
  #5  
Old 04-02-2009, 03:05 PM
Compression Ignition Addict
 

Join Date: Mar 2008
Location: S.E. PA.
Posts: 206
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2 fresh one's ALWAYS with that type of situation 4 me .
Reply With Quote Quick reply to this message
  #6  
Old 04-06-2009, 06:29 AM
Powerstroke.org Rookie
 

Join Date: Aug 2007
Location: bakersfield
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Update. I had to replace the alt again. I opened my hood to find the alt had scatterd. I replaced it with a new higher amperage one, and it has lasted a big 3 days now.
Reply With Quote Quick reply to this message
  #7  
Old 04-06-2009, 06:31 AM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,007
Thanks: 0
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
i had that problem about 4 years ago in my 7.3. had one rebuilt, then replaced, replaced again. alone with about 4 batteries in the whole course of that from ppl who had no idea what to do. BUT it's all good now and have only had to replace the batteries once since then. just normal wear on them
Reply With Quote Quick reply to this message
  #8  
Old 10-10-2009, 12:13 PM
Member
 

Join Date: Jun 2009
Posts: 53
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
where did you get the scattered alt?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:37 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors