need help please - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-30-2014, 05:09 PM
Member
 

Join Date: Jan 2013
Location: circleville ut
Posts: 53
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
need help please

I have a late 04 160000 miles on it. my oil cooler plugged up so I put a new cooler hpop stand pipes and dummy plugs and egr delete this was about a year ago. now my eot and ect was running high so I put another cooler in to make a long story short it was my radiator plugged after putting a new one my ect stays around 190 and eot pulling a little hill empty runs around 215 I have also put a new water pump front cover and electric fan does anyone have any ideas on what else could be the problem sorry for the long post any advice would be helpful thanks ps I did flush the system with vc9 before doing the new oil cooler and radiator

Last edited by dj.oneil; 07-30-2014 at 05:22 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-31-2014, 04:46 AM
Member
 

Join Date: Jul 2009
Location: Golden Valley
Posts: 71
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
You need to check eot and ect deltas on flat road at 65 mph. no hills or load on truck.
Reply With Quote Quick reply to this message
  #3  
Old 07-31-2014, 07:51 PM
6LeakerTweaker
 

Join Date: Feb 2010
Location: Athens, Ga
Posts: 832
Thanks: 0
Thanked 26 Times in 24 Posts
Feedback Score: 0 reviews
^^^^X's 2 on this. Also, have you flushed the coolant system properly? If not you are most likely going to plug up your oil cooler again.

Jeremy
Reply With Quote Quick reply to this message
  #4  
Old 07-31-2014, 08:37 PM
Member
 

Join Date: Jan 2013
Location: circleville ut
Posts: 53
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
On flat ground it's between 5 &10 degrees different of each other ect stays around 187 and eot stays around 195 to 200 on the flat. I used 2 quarts of vc9 with each flush and got my ect up around 215 and drove it that way for about 2 hours and back flushed it each time before and after the vc9
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:57 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors