Glowplug failure help! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-28-2014, 06:30 AM
Powerstroke.org Rookie
 

Join Date: Oct 2013
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Glowplug failure help!

Hey guys looking for a little help with my truck, shes a 2004 f-250 6.0l with 110,000 miles on her and lately ive been getting codes for "glowplug circuit failure" on cylinders 1,3 and 7 i went ahead and replaced the passenger side g.p harness and i am still getting the same codes. Is it possible all 3 glow plugs are bad? (Seems odd 3/4 would go on the same side) or is it my gpcm? Tested the gpcm last week and it read it was within spec (possible im doing somethi g wrong?) Any and all help,advice, opinions is greatly appreciated


Tom
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-29-2014, 09:13 AM
Serving Our Country!
 

Join Date: Apr 2013
Location: Washington State
Posts: 155
Thanks: 0
Thanked 6 Times in 6 Posts
Feedback Score: 0 reviews
I am curious to hear what you find out because I just got a check engine light with a P0678 code which indicates an issue with the cylinder 8 glow plug circuit. Since I will be working on it after work, I am planning on buying the harness and 4 glow plugs and doing all the ones on the drivers side since I have already invested the time removing the interference.

I am curious how long it took you to do the job and if there is anything you know NOW that you wish you knew before you started the job.

Thanks.
Reply With Quote Quick reply to this message
  #3  
Old 08-01-2014, 08:53 AM
Serving Our Country!
 

Join Date: Apr 2013
Location: Washington State
Posts: 155
Thanks: 0
Thanked 6 Times in 6 Posts
Feedback Score: 0 reviews
So, I removed the inner fenderwell cover and carefully removed the glow plug harness connector and replaced #8 cylinder glow plug (it was suprisingly easy) and reconnected the harness. I then cleared the code and started the truck. No more check engine light... Woo Hoo! Then, the next day I got the P0678 code again. I cleared it and it stayed off until the next day which was yesterday.

I am kicking myself for going the more cost effective route ( aka cheaper route ) and replacing only the one then returning all the parts. I should have executed the plan I had and replaced all the ones on that side including the harness while I had it apart!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:13 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors