Bad turbo seal.. again?? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-23-2014, 06:09 AM
Member
 

Join Date: Jan 2014
Posts: 62
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Bad turbo seal.. again??

I've scanned the forums for a long time now and stay so busy I don't ever have time anymore. So recently i pulled my turbo and replaced the bearings and seals based of prior findings of blowing white smoke only after idle when pulling out thus the burning of oil. Still blowing smoke after the replacement of the bearings and seals with only 1500ish miles on the new parts.. Could the hotside housing where the seal seats be worn out, allowing the oil to pass through?

Truck specs:
118k miles
SCT livewire w/ Gearhead and Innovative tunes
4in mbrp exhaust
k&n intake
Wicked wheel 2 (installed at the same time as bearing and seal replacement)
JMS egt probe

:edit: blue spring also.
sinister coolant filter kit.
Ill keep adding parts as I remember

-All temps (oil,coolant) are within specs staying about 3-4degrees different when finally warmed up.
-FICM 48-49V
-EGT never getting above 900
-ICP psi @580 when full operating temps reached.


A1 studs
Oil cooler
egr delete

These 3 replaced within last 2k miles.

Last edited by PowertotheStoke; 07-23-2014 at 06:24 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-23-2014, 07:01 AM
Compression Ignition Addict
 

Join Date: Feb 2008
Posts: 8,443
Thanks: 72
Thanked 215 Times in 203 Posts
Feedback Score: 0 reviews
you won't like this but i would pull the K&N first
Reply With Quote Quick reply to this message
  #3  
Old 07-23-2014, 07:12 AM
Member
 

Join Date: Jan 2014
Posts: 62
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by ZMANN View Post
you won't like this but i would pull the K&N first
Yeah I know the k&n has bad reps on these trucks but i've not had a problem with mine and that has nothing to do with the burning of oil or smoke problem. Though I have been meaning to do the ccv mod but haven't had a chance yet.

I do plan on getting an s&b if this problem prolongs into the purchase of a new turbo but until then with proper maintenance, I'll keep the k&n
Reply With Quote Quick reply to this message
  #4  
Old 07-23-2014, 05:32 PM
Member
 

Join Date: Jan 2014
Posts: 62
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
I plugged the egr valve in but left the block plate on and left the valve sitting there and no smoke..
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:41 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors